Sign in to follow this  
Followers 0
Rikux

ListBox1 problem

1 post in this topic

Hello

Been fighting with this for a long time now so some help would be great :whistle:

I have a software I'm using AutoIt v3 (tried with newest beta, too) to control. There's listview with several lines of log-text. I know it's class name is ListBox1 even though Active Window Info doesn't recognize it at all.

Now here's problem. I can use ControlCommand("Application name", "", "ListBox1", GetCurrentSelection", "") without any problems, it returns selected line every time. However, I can't get one single other command to work on it. I cannot use GetLineCount, result is always 0. Neither can I use GetLine, result is always 1 etc etc.

I have my doubts that the listview in question is of type ComboLBox which might cause some problems... Right now I can read result from it without problems if there's just one line with GetCurrentSelection as it returns the first line even if it's not selected (e.g. highlighted).

Anyone have any idea what's going on and if there's something I can do? My whole project is going down the drain because of this, it's vital listView with all the info I need to get my hands on. Help please!

Ps. I have also tried ControlGetText (result is always empty string) and GuiCtrlRead (always 0) ControlListView (always empty).

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0