Sign in to follow this  
Followers 0
Otacon

IE.au3 - If Number on Website is larger than?

3 posts in this topic

Hello Everyone.

I'm currently trying to figure out how i can do this.

I got a website open using _IECreate. I navigate to a subside clicking a bunch of links.

Now on the page there are two statistics Numbers.

One is "654 %" but it can be "1.654 %" so using a dot as seperator for thousand.

The second one is "654 gb" or "1.654 gb", so basically the same shit, just a different unit.

The text is exactly like shown above. A number, with a dot a seperator for more than 3 digits, followed by that symbol.

How can i check for those numbers? Or would i need to be more specific, like analizing the text around it?

The whole line where those numbers occur is like this.

"Restmenge: 625 gb und 1.654 % Speicherplatz"

I need my script to react correspondingly if one of those numbers rises above 1.000. I just need to figure out IF they did rise above it, and which one did, but not by how much.

I got no clue on how to tackle that problem. Any advice pointing me in the right direction is appreciated :)

And for German Speakers, yeah "Speicherplatz" can really rise above 1.000%. I know thats weird lol.

Share this post


Link to post
Share on other sites



You can use _IEBodyReadText and _StringBetween

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

_StringBetween seems to be what i have been missing. Thanks :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0