Sign in to follow this  
Followers 0
Geotab

Trouble filling in UPS WorldShip entries

1 post in this topic

I am trying to automate the process of filling up entries in the UPS WorldShip window but for some reason, almost all the auto functions don't seem to work on it. The UPS WorldShip look like the following:

http://www.google.ca/imgres?um=1&hl=en&sa=N&tbo=d&rlz=1C1TSNP_enCA502CA502&biw=1920&bih=955&authuser=0&tbm=isch&tbnid=LhiSzF4j1Gg3nM:&imgrefurl=http://help.ablecommerce.com/mergedprojects/ac55merchant/shipping/ups/import_orders_to_worldship.htm&docid=lvQPx3wY1wgzIM&imgurl=http://help.ablecommerce.com/mergedprojects/ac55merchant/image20.jpg&w=649&h=562&ei=eTHTUJ27E5CB0AH0zoHADg&zoom=1&iact=rc&dur=1&sig=111811788756567599707&page=1&tbnh=144&tbnw=166&start=0&ndsp=49&ved=1t:429,r:0,s:0,i:88&tx=78&ty=79

When I use the Finder tool from the window info on one of the entries, (attention for this specific example), I get the following from the control window:

Class: Edit

Instance: 5

ClassnameNN: Edit5

etc.

What I want to do is pretty simple, I just want to input some string into it. So I tried using controlsettext by running a command like

controlsettext("UPS WorldShip","","[CLASS:Edit; INSTANCE:5]","text"), but nothing will fill the textbox and I would get run /prod /ErrorStdOut at the bottom of the script.

I've tried other control commands too such as controlclick, controlcommand, and controlsend but autoit can't seems to recognize the control for that textbox. However, if I try the same thing on other windows, such as notepad, it works perfectly fine.

Any help or insight on this would be greatly appreciated.

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0