Sign in to follow this  
Followers 0
IanN1990

[Sloved] _IELoadWait fails on PC Lock

6 posts in this topic

#1 ·  Posted (edited)

Is there any way to make the function work when the computer is locked ?

Windows 7 Proffesional N x64

Edited by IanN1990

Share this post


Link to post
Share on other sites



"fails" is a totally inadequate problem description.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Fail enough :) Both functions are ment to pause the script until the page "has been loaded" and let then the script carry on. but when the pc is loaded it remains in loop 4ever. Even if the page has been loaded.

Share this post


Link to post
Share on other sites

Did you read the remarks section for _IELoadWait? That function can fail for many reasons, you may need alternate ways of checking that the page has finished loading.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

As I said, your problem description is totally inadequate.

This example shows you there is no systemic problem with what you are trying to do:

#include <IE.au3>
ConsoleWrite("Start, lock system - " & @MIN & ":" & @SEC & @CRLF)
sleep(20000) ; give time to lock system
ConsoleWrite("Issue _IECreate - " & @MIN & ":" & @SEC & @CRLF)
_IECreate("[url="http://www.autoitscript.com"]http://www.autoitscript.com[/url]", 0, 1, 1)
ConsoleWrite("_IECreate completed - " & @MIN & ":" & @SEC & @CRLF)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Seams i might be mistaken then.

#include <IE.au3>
ConsoleWrite("Issue _IECreate - " & @MIN & ":" & @SEC & @CRLF)
Run('C:\Windows\System32\rundll32.exe user32.dll,LockWorkStation')
_IECreate("www.google.com", 0, 1, 1)
ConsoleWrite("_IECreate completed - " & @MIN & ":" & @SEC & @CRLF)

I guess i assumed when i logged back in and the page was not being displayed correctly i figured the code had failed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0