Sign in to follow this  
Followers 0
swissroach

Keyboard-shortcuts in SciTE not working (e.g. ALT+F6 for AU3Recorder or any other combination)

3 posts in this topic

Dear AutoIT volunteers and users

I'm new to AutoIT and I just want to give it a try as alternative method for some manual installations and other things (automating things which can't be automated with GPO's, Registry-entries and and and).

Now I've got a problem which i believe I'm not the only one with it... but i didn't found a matching thread with searching in these forums or with google (maybe if i spent some more hours.... reading trough all the search results)...

I can't use any shortcuts in SciTE. Now I believe the problem is within the $(SciteDefaultHome) variable.

I've found these entries in the properties files:

# 07 AU3Record program
#~ command.7.$(au3)="$(SciteDefaultHome)\ScriptWriter\AU3record.exe" /o
command.7.$(au3)="$(SciteDefaultHome)\AutoIt3Wrapper\AutoIt3Wrapper.exe" /AU3Record

When i run the commands in the command line console, it runs without any problems but when i hit the keyboard-combination for it inside SciTE, it doesn't do anything, it seems to don't even try to open something.

I've got a Win7 Enterprise with newest updates, x64 version, normally working without admin rights but starting the SciTE with admin login prompt (but doesn't run without admin rights (-> as a normal user) either).

Can anyone maybe give me an advice on where to search for the problem? Is there a way to define the scitedefaulthome variable or do i have to start SciTE with a special parameter?

If there is a thread with the same problem and a solution: I'm really sorry to post this again, I'm going to get myself new glasses... :)

Best regards and thanks to everyone involved for their work on AutoIT and its components!

Share this post


Link to post
Share on other sites



Most of the tools need you to have a file saved as a *.au3 file before you can activate them, even if the file is empty as long as it's been saved the tools show up in the Tools menu.

1 person likes this

If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

Omg... I'm sure I tried this before with a saved document... anyway now it works, thanks! Maybe there was a reboot needed before this works... can't explain this behaviour in another way.

Nevermind... just wrote this if someone else have this problem and there's really a reboot needed.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0