Jump to content
Sign in to follow this  
DerekOH

Starting Skype video call with Skype4COM

Recommended Posts

DerekOH

Hi,

I've got a script created in AutoIT, using the Skype4COM API to automatically dial another Skype user when a specific keystroke is pressed. Once the call is established, I then use the API to turn-on both video send and receive. As the call is between two pre-determined contacts, I also have the Skype options set at both ends to automatically start video sharing (this is for a point-to-point video setup).

Most of the time this works fine, but sometimes (perhaps 1-in-5 times), the PC establishing the call doesn't display the video window - it just stays on the Skype Home screen window. Video is still being sent and received, but just not being displayed in a window on the screen.

Is there a way to determine why this is happening or, even better, to ensure video is visible?

At the moment, I make the Skype screen active/focused, then send the ALT-ENTER keystroke to make it full-screen. The problem is that sometimes the video window isn't shown, so this can't work.

Any ideas?

Thanks

Share this post


Link to post
Share on other sites
JLogan3o13

Hi, DerekOH, welcome to the forum. As a general rule, it is always best to post what code you have, or at least a working reproducer. Otherwise, you're asking someone to guess at reproducing your script and then find the bugs :)


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.