Jump to content
Sign in to follow this  
vij

_IECreate giving errors - Help!

Recommended Posts

vij

I have used IE UDF a bit before and had no problems, but it seems to cause problems with certain rss feed urls for some reason.

EX:

#include<IE.au3>
_IECreate("http://ragecraftrc.net/extern.php?action=feed&type=atom")

Gives this error :geek:

C:\Program Files (x86)\AutoIt3\Include\IE.au3 (561) : ==> The requested action with this object has failed.:
While Not (String($o_object.document.readyState) = "complete" Or $o_object.document.readyState = 4 Or $f_Abort)
While Not (String($o_object.document.readyState^ ERROR

The url opens but with some lag.

Manually, the url opens quick and easy(with IECreate it opens but with a lag) - and screws up something with IE UDF

I am using Internet Explorer 10

Any idea?

Edited by vij

Share this post


Link to post
Share on other sites
vij

The script works if I turn off "Feed Reading" within Internet Explorer options - ofcourse the feed page is then displayed as source code then - but doesnt hamper what I want to do overall.

Another work around to what I eventually want to achieve is using the Chilkat ActiveX component http://www.chilkatsoft.com/refdoc/xSpiderRef.html - that way I dont have to even open feed urls with IE.

Doesnt change the fact that something isnt right when you try to work IE UDF with feed urls.

Edited by vij

Share this post


Link to post
Share on other sites
MouseSpotter

View the page source ... you'll find that the web document is not HTML ... it is XML.

Thismay mean that the IE DOM is not being used and therefore the objects are non-existent.

Share this post


Link to post
Share on other sites
DaleHohm

View the page source ... you'll find that the web document is not HTML ... it is XML.

Thismay mean that the IE DOM is not being used and therefore the objects are non-existent.

Correct

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×