Jump to content
Sign in to follow this  
Annonyreeder

Different sort of button cannot click with _IE

Recommended Posts

Annonyreeder

Hello,

I have been making a auto account creation script for an application used at work (E-ID/Equafax)

And i have more or less completed it however threes one button at the end i can't seem to click,

When i look at the page source it shows as;

<button class="action af_commandButton" onclick="submitForm('ManageUsers',1,{source:'_id106:_id133'});return false;" type="button">

Text - Assign

All the other buttons ive worked with have had names or IDS and have been able to click them with _IEgetobjname/id

Help is appreciated,

thanks.

Ant

Share this post


Link to post
Share on other sites
Danp2

Take a look at _IEFormElementGetCollection or _IETagNameGetCollection. You should be able to get a collection of the elements using one of these functions and then loop through the collection until you find the desired button.

Share this post


Link to post
Share on other sites
Annonyreeder

well i can get the form, although i already new the form name anyways how do i use that as i already tried formgetelement//Submit form, but this has not worked

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×