Sign in to follow this  
Followers 0
van_renier

Error in include IE.au3, using _IECreate

8 posts in this topic

I just downloaded v3.3.8.1 on a new system (no previous au3 installation). I'm trying to automate the loading of websites, to validate the URLS are working as expected.

The error must be occurring on the _IECreate() line (as the error occurs almost immeditely suggesting the script is not even getting to the 'sleep' line.

The error message is:

=======================

Line 560  (File "C:\Program Files (x86)\AutoIt3\Include\IE.au3"):

WEnd
WEnd^ ERROR

Error: The requested action with this object has failed.

=======================

Here is my code where I'm getting the error:

==================

#include <IE.au3>

; 2. Login to Sharepoint
; http://portal.fhlbi.com/Pages/Default.aspx
Local $oIE = _IECreate("http://portal.fhlbi.com/Pages/", 0, 1, 1, 1)
sleep ( 15500 )
Local $sHTML = _IEBodyReadHTML($oIE)
$sHTML = $sHTML & "<p><font color=red size=+5>Big RED text!</font>"
_IEBodyWriteHTML($oIE, $sHTML)

==================

Any suggestions would be greatly appreciated.

 

Thanks,

Van

 

Share this post


Link to post
Share on other sites



Groovy, Thanks Jos!

Share this post


Link to post
Share on other sites

Crap.. downloaded/applied it, and now getting this error:

==================

Line 396  (File "C:\Program Files (x86)\AutoIt3\Include\IE.au3"):

$s_tmp = $o_window.type
$s_tmp = $o_window.type^ ERROR

Error: The requested action with this object has failed.

==================

Share this post


Link to post
Share on other sites

Using the same script, if I change the attach attempt to 0 (zero), as in:

==================

Local $oIE = _IECreate("http://portal.fhlbi.com/Pages/", 0, 1, 1, 1)
==================

I get this error:

==================

Line 3690  (File "C:\Program Files (x86)\AutoIt3\Include\IE.au3"):

Local $oTemp = $o_object.document
Local $oTemp = $o_object.document^ ERROR

Error: The requested action with this object has failed.

==================

If set the attach to 1, as in:

==================

Local $oIE = _IECreate("http://portal.fhlbi.com/Pages/", 0, 1, 1, 1)
==================

I get this error:

==================

Line 396  (File "C:\Program Files (x86)\AutoIt3\Include\IE.au3"):

$s_tmp = $o_window.type
$s_tmp = $o_window.type^ ERROR

Error: The requested action with this object has failed.

==================

Share this post


Link to post
Share on other sites

Requires AutoIt3 3.3.9 or higher

Share this post


Link to post
Share on other sites

ah, Thanks Dan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0