Jump to content
Sign in to follow this  
JomarSevillejo

Buttons disabled after adding background image

Recommended Posts

JomarSevillejo

Good day everyone! I am facing a small problem here..
I am new to autoIT and therefore I have a few questions to ask.

I have made a GUI using KODA form Designer.
I've added buttons and input boxes, then I decided to add a background image to the GUI using "Picture" from the tab "Additional", but when I did, all buttons and other GUI elements were unclickable.

Why is this?

Is there a "proper way" of adding a background image?

Thanks in advance!

Share this post


Link to post
Share on other sites
FireFox

Hi,

If you read carefully the helpfile it's stated :

If a picture is set as a background picture, as the other controls will overlap, it is important to disable the pic control: GUICtrlSetState(-1, $GUI_DISABLE).

But there are many people like you who asked the same question so a quick forum search would have led you to the anwser ;)

Br, FireFox.

  • Like 1

 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites
JomarSevillejo

Hi,

If you read carefully the helpfile it's stated :

But there are many people like you who asked the same question so a quick forum search would have led you to the anwser ;)

Br, FireFox.

Funny how I found that in the help file just now xD

Anyways, thanks!

I got it solved by changing the order in which the GUI elements are made :D

Since it said "Overlap" then it must have been on top..

Share this post


Link to post
Share on other sites
FireFox

I got it solved by changing the order in which the GUI elements are made :D

Since it said "Overlap" then it must have been on top..

This "workaround" won't work for some cases ;)

 

OS : Win XP SP2 (32 bits) / Win 7 SP1 (64 bits) / Win 8 (64 bits) | Autoit version: latest stable / beta.
Hardware : Intel(R) Core(TM) i5-2400 CPU @ 3.10Ghz / 8 GiB RAM DDR3.

My UDFs : Skype UDF | TrayIconEx UDF | GUI Panel UDF | Excel XML UDF | Is_Pressed_UDF

My Projects : YouTube Multi-downloader | FTP Easy-UP | Lock'n | WinKill | AVICapture | Skype TM | Tap Maker | ShellNew | Scriptner | Const Replacer | FT_Pocket | Chrome theme maker

My Examples : Capture toolIP Camera | Crosshair | Draw Captured Region | Picture Screensaver | Jscreenfix | Drivetemp | Picture viewer

My Snippets : Basic TCP | Systray_GetIconIndex | Intercept End task | Winpcap various | Advanced HotKeySet | Transparent Edit control

 

Share this post


Link to post
Share on other sites
Edano

This "workaround" won't work for some cases ;)

.

as soon as you click the pic, it will overlap again ;)

  • Like 1

[color=rgb(255,0,0);][font="'comic sans ms', cursive;"]FukuLeaks[/color][/font]

Share this post


Link to post
Share on other sites
JomarSevillejo

.

as soon as you click the pic, it will overlap again ;)

Thanks for the info!

I also have a small partion where a picture changes dynamically. With the info you've given I now know what to avoid.. Thanks!

Share this post


Link to post
Share on other sites
Edano

you should prefer to disable it like firefox said....

  • Like 1

[color=rgb(255,0,0);][font="'comic sans ms', cursive;"]FukuLeaks[/color][/font]

Share this post


Link to post
Share on other sites
JomarSevillejo

you should prefer to disable it like firefox said....

Oh Okay thanks, I will. I don't see any reason why I shouldn't :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×