Jump to content
Sign in to follow this  
blashmet

Unknown Function Name

Recommended Posts

blashmet

I generated a script using the option Tools->Au3 Record.  It's a simple installer:  I clicked next a few times, unchecked a few boxes, and clicked finish. The code looks like this:

#region ---Au3Recorder generated code Start (v3.3.7.0)  ---
 
Run('C:AginityNetezzaWorkbenchSetupx64.exe')
_WinWaitActivate("Aginity Workbench for Netezza - InstallAware Wizard","")
MouseClick("left",415,392,1)
MouseClick("left",419,519,1)
MouseClick("left",342,372,1)
MouseClick("left",413,526,1)
MouseClick("left",413,526,1)
MouseClick("left",413,526,1)
MouseClick("left",344,237,1)
MouseClick("left",422,531,1)
#endregion --- Au3Recorder generated code End ---
 
However, when I run the .exe compiled from the script, I get this error:
 
ERROR: _WinWaitActivate(): undefined function.
 
I've tried re-recoding the macro with the option "Create internal functions" checked, but I get the same error.
 
Any ideas how to fix?
 
Thanks! :)
 

Share this post


Link to post
Share on other sites
basel1998

click on "Generate Internal functions"

and then change line 16 from "AU3RecordSetup()" to "_AU3RecordSetup()"

Share this post


Link to post
Share on other sites
blashmet

Yeah...I figured that out before returning here.

Is this a known bug?  Does it always misuse function names when using the recorder?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×