Jump to content
Sign in to follow this  
Hyflex

Compiled script failing to take the icon provided...

Recommended Posts

Hyflex

Pretty simply the compiled script called "Export Data" is not using the icon I provided...

Anyone know why this is and anyone know how to fix it?
 

wct9Fj7.png
 

Thanks in advance

- X

Share this post


Link to post
Share on other sites
DW1

Is the icon "Export Data.ico" in the same directory as the script?  I assume so since there is no path listed, and I doubt you just typed the name in manually.

What do you see in the SciTE console?

What sizes are present in the ico file?

Share this post


Link to post
Share on other sites
Hyflex

nvm

Edited by Hyflex

Share this post


Link to post
Share on other sites
Hyflex

Yes, it is in the same directory as you can see the image to the right to the right of the normal compression.
 

+>02:57:52 Starting AutoIt3Wrapper v.2.1.2.9    Environment(Language:0409  Keyboard:00000809  OS:WIN_7/Service Pack 1  CPU:X64 OS:X64)
-> No changes made..
>Running AU3Check (1.54.22.0)  from:C:\Program Files (x86)\AutoIt3
+>02:57:58 AU3Check ended.rc:0
>Running:(3.3.8.1):C:\Program Files (x86)\AutoIt3\aut2exe\aut2exe.exe  /in "C:\Users\A\Desktop\Export Data.au3" /out "C:\Users\A\AppData\Local\Temp\~AU3wlenhri.exe" /nopack /icon "C:\Users\A\Desktop\Export Data.ico" /comp 2
+>02:58:04 Aut2exe.exe ended.rc:0
+>02:58:04 Created program:C:\Users\A\Desktop\Export Data.exe
>Exit code: 0    Time: 13.023

As for icon sizes, in this example I used: 

http://www.iconarchive.com/show/ivista-2-icons-by-gakuseisean/Files-Copy-File-icon.html

Share this post


Link to post
Share on other sites
DW1

 

Yes, it is in the same directory as you can see the image to the right to the right of the normal compression.

 

+>02:57:52 Starting AutoIt3Wrapper v.2.1.2.9    Environment(Language:0409  Keyboard:00000809  OS:WIN_7/Service Pack 1  CPU:X64 OS:X64)
-> No changes made..
>Running AU3Check (1.54.22.0)  from:C:\Program Files (x86)\AutoIt3
+>02:57:58 AU3Check ended.rc:0
>Running:(3.3.8.1):C:\Program Files (x86)\AutoIt3\aut2exe\aut2exe.exe  /in "C:\Users\A\Desktop\Export Data.au3" /out "C:\Users\A\AppData\Local\Temp\~AU3wlenhri.exe" /nopack /icon "C:\Users\A\Desktop\Export Data.ico" /comp 2
+>02:58:04 Aut2exe.exe ended.rc:0
+>02:58:04 Created program:C:\Users\A\Desktop\Export Data.exe
>Exit code: 0    Time: 13.023

As for icon sizes, in this example I used: 

http://www.iconarchive.com/show/ivista-2-icons-by-gakuseisean/Files-Copy-File-icon.html

Sorry for the delay, got stuck playing Pixeljunk Monsters :P

The ico file you linked has some VERY low quality images within it in addition to the high quality ones.  I removed all but the high quality images from the ico file and now it works fine.

Download the modified file below and let us know how it goes

Export Data.ico

Edited by danwilli

Share this post


Link to post
Share on other sites
Hyflex

Works wonderfully, would you be so kind in giving a few instructions on how to fix icons like this?

Thanks

Share this post


Link to post
Share on other sites
Hyflex

Bump, anyone know how he did it?

Share this post


Link to post
Share on other sites
DW1

You could use an icon editor like Greenfish or IcoFx (both Free) to remove unwanted quality icons.

Greenfish Icon Editor Pro Portable

IcoFX Portable

Right on the money!  I used IcoFX :)  It will show you the contents of the ico file and you can remove entries, add and modify entries, and likely much more that I never use.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×