Jump to content
Sign in to follow this  
cztchoice

_IEAttach don't work with MDict program

Recommended Posts

cztchoice

MDict is a dict program, it can be download here: http://www.octopus-studio.com/download.en.htm

The direct download link is here:

 http://www.octopus-studio.com/download/MDictPC.zip

It has a Internet Explorer_Server Control Instance, and i want to get the html body text of it.

when use the Au3Info I get the follow Summary:

>>>> Window <<<<
Title:  MDict
Class:  MDictMainWnd
Position:   285, 206
Size:   953, 593
Style:  0x16CF0000
ExStyle:    0x00040100
Handle: 0x001C070A

>>>> Control <<<<
Class:  Internet Explorer_Server
Instance:   1
ClassnameNN:    Internet Explorer_Server1
Name:   
Advanced (Class):   [CLASS:Internet Explorer_Server; INSTANCE:1]
ID: 
Text:   
Position:   218, 74
Size:   713, 470
ControlClick Coords:    594, 154
Style:  0x56000000
ExStyle:    0x00000000
Handle: 0x016E04FA

>>>> Mouse <<<<
Position:   1106, 470
Cursor ID:  0
Color:  0xCCE8CF

>>>> StatusBar <<<<

>>>> ToolsBar <<<<

>>>> Visible Text <<<<
Microsoft Lili - Chinese (China)


>>>> Hidden Text <<<<

but when i use this code,

#include <IE.au3>
$oIE = _IEAttach ("MDict", "Embedded")
$sText = _IEBodyReadText ($oIE)
MsgBox(0, _IEPropertyGet ($oIE, "locationurl"), $sText) 

I always get this error:

IE.au3 T3.0-1 Warning from function _IEAttach, $_IEStatus_NoMatch (0)

I've tried to use this code in other application, such as the windows helper, it works well, and output the text i want.

but i tried this on my Windows 7 X64, Windows 7 X86, Windows XP machine, it always gives me the same error.

And I don't know why this happen, can anyone give me some advice?

Thanks.

Edited by cztchoice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×