Sign in to follow this  
Followers 0
GordonShumway

Install on Windows 8 result in no context menu (no Edit/Run/Tidy/etc)

4 posts in this topic

Hi fellow AutoIt users,

I have a annoying issue after installing AutoIt on my new Windows 8.1 Pro 64bit computer. I have no context menu entries whatsoever for AutoIt !

It seems that I'm the first with this problem. Or I did not search good enough...

Anyway, my problem seems rare. Elsewhere I found somebody who had similar problems with another program, but his solution did not solve my problem.

So, what IS my problem (in more detail):

- After years-and-years of no problems in XP, I've bought a new PC and installed the same AutoIt V3.3.8.1 (several times, running the installer normally and "run as admin", and also with different x86/x64 options (forgot the exact text)).

- After the succesfull installation, there are no context menu entries to be found.

- No "right-click on empty space => New autoit script" (although this file exists "C:WindowsShellNewTemplate.au3").

- And No "right-click on an .au3 file" with the expected possibilities as "Edit/Run/Tidy/Compile/etc".

What did I try to resolve this issue:

- Running the installer normally and "run as admin" (as mentioned earlier).

- Disabling UAC did not help.

- Creating a non-admin account and perform a right-click on an existing ..au3 file (again: no success).

- Inspecting the registry for any obvious flaws (I'm no expert, so just a visual scan).

I've made a workaround which consists of:

- Editing: Assigning file extension .au3 to Scite.

- Running: Right-click on an .au3 file => Send To => Run Script (x64).

I won't publish every registry line with "AutoIt" in it, but the most relevant portions look like this:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script]
@="AutoIt v3 Script"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\DefaultIcon]
@="C:\\Program Files (x86)\\AutoIt3\\Icons\\au3script_v10.ico"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell]
@="Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Compile]
@="Compile Script"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Compile\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\Aut2Exe\\Aut2Exe_x64.exe\" /in \"%l\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Compile with Options]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Compile with Options\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\SciTE\\AutoIt3Wrapper\\AutoIt3Wrapper.exe\" /ShowGui /in \"%l\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\CompileX64]
@="Compile Script (x64)"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\CompileX64\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\Aut2Exe\\Aut2Exe_x64.exe\" /in \"%l\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\CompileX86]
@="Compile Script (x86)"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\CompileX86\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\Aut2Exe\\Aut2Exe.exe\" /in \"%l\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Edit]
@="Edit Script"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Edit\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\SciTE\\SciTE.exe\" \"%1\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Open]
@="Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Open\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\SciTE\\SciTE.exe\" \"%1\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Run]
@="Run Script"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Run\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\AutoIt3_x64.exe\" \"%1\" %*"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\RunX64]
@="Run Script (x64)"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\RunX64\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\AutoIt3_x64.exe\" \"%1\" %*"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\RunX86]
@="Run Script (x86)"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\RunX86\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\AutoIt3.exe\" \"%1\" %*"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Tidy]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\AutoIt3Script\Shell\Tidy\Command]
@="\"C:\\Program Files (x86)\\AutoIt3\\SciTE\\Tidy\\Tidy.exe\" \"%1\""
 
Also, in HKEY_CLASSES_ROOT is a very similar key (like the one above).
 

Any help in solving this issue is very much appreciated.

Kind regards,

Gordon

(from the Netherlands)

Share this post


Link to post
Share on other sites



Gordon,

Do you have the latest Full SciTE4AUtoIt3 installed? If so, you can  run SciTEConfig (Ctrl+1) and select the "Other tools" Tab. On these you Select "Run AutoIt3 Registry Check".

That should tell you about any issues with the registry in case that is the issue.

Groet,

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Unfortunately starting with Windows 8 Microsoft don't allow programs to force file associations using those reg keys. Well, you can but the user also has to perform some actions to make the decision as to the default program which is used to open the file. If the user's choice matches the settings in those reg keys then you should see the context entries again.

Try this:

- Right click a .au3 file

- Select Open with / Choose Default Program

- Select the version of AutoIt

Normally with clean installs this wouldn't come up as there would only be one default. But I get it a lot with the multiple versions of AutoIt stable / beta versions.

Edit: It could also happen if you choose to edit the script with a different program because Windows would then only show context entries for that editor.

Share this post


Link to post
Share on other sites

@Jon. Thanks for trying to help me out. But Jos' response was the one I tried first. And that one worked!

@Jos. Yes, I've got the latest full scite. This is what the registry check displayed:

******************************************************************************************************************************************
!*  Found always open with Win7    :Applications\SciTE.exe
!*  Fixed by removing Registry key : "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.au3\Userchoice"
!*  Registry key: "HKCR\.au3" - "Default" is currently set to au3_auto_file   ==> This should be changed to "AutoIt3Script" (or "AutoIt3ScriptBeta")
* HKCR\.au3 ShellNew      :C:\Windows\SHELLNEW\Template.au3 (File Exists)
******************************************************************************************************************************************
* Explorer shell options:
* HKCR\au3_auto_file\shell: 
*  => Default Action:
******************************************************************************************************************************************

I executed this advise "!*  Registry key: "HKCR.au3" - "Default" is currently set to au3_auto_file   ==> This should be changed to "AutoIt3Script" (or "AutoIt3ScriptBeta")"

And after a reboot, one issue was solved!  :)  I could once again do a "right-click on empty space => New autoit script".

Great, but the other issue (no "Edit/Run/Tidy/Compile/etc") still existed.  :mad:

I wouldn't give up that easily (I've spend allready so much hours searching for a solution), and I did your " registry check trick" again:

******************************************************************************************************************************************
!*  Found always open with Win7    :Applications\SciTE.exe
!*  Fixed by removing Registry key : "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.au3\Userchoice"
* HKCR\.au3 Default       :AutoIt3Script
* HKCR\.au3 ShellNew      :C:\Windows\SHELLNEW\Template.au3 (File Exists)
******************************************************************************************************************************************
* Explorer shell options:
* HKCR\AutoIt3Script\shell: 
*  => Default Action:Open
*     Compile                => Command:"C:\Program Files (x86)\AutoIt3\Aut2Exe\Aut2Exe_x64.exe" /in "%l"
*     Compile with Options   => Command:"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /ShowGui /in "%l"
*     CompileX64             => Command:"C:\Program Files (x86)\AutoIt3\Aut2Exe\Aut2Exe_x64.exe" /in "%l"
*     CompileX86             => Command:"C:\Program Files (x86)\AutoIt3\Aut2Exe\Aut2Exe.exe" /in "%l"
*     Edit                   => Command:"C:\Program Files (x86)\AutoIt3\SciTE\SciTE.exe" "%1"
*     Open                   => Command:"C:\Program Files (x86)\AutoIt3\SciTE\SciTE.exe" "%1"
*     Run                    => Command:"C:\Program Files (x86)\AutoIt3\AutoIt3_x64.exe" "%1" %*
*     RunX64                 => Command:"C:\Program Files (x86)\AutoIt3\AutoIt3_x64.exe" "%1" %*
*     RunX86                 => Command:"C:\Program Files (x86)\AutoIt3\AutoIt3.exe" "%1" %*
*     Tidy                   => Command:"C:\Program Files (x86)\AutoIt3\SciTE\Tidy\Tidy.exe" "%1"
******************************************************************************************************************************************

And this looked so much better; that I started reading the "!*"-lines over-and-over

I decided to executed the second advise (after a registry key export, I'm no registry hero): "!*  Fixed by removing Registry key : "HKCUSoftwareMicrosoftWindowsCurrentVersionExplorerFileExts.au3Userchoice""

And after the second reboot; this issue was solved too! I'm over the moon  :P

Now I can  "right-click on an .au3 file => Edit/Run/Tidy/Compile/etc".

I've read a nice thank-you somewhere else.

It was something like: "I don't know what they are paying you, but it's not nearly enough!:cheer:

Hopefully this topic will help somebody else.

Once again: thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0