Jump to content
Sign in to follow this  
stefan654

Autoit not working on my client on a VM

Recommended Posts

stefan654

so i've been using a script on my own computer for a while now.

today i decided to let it run on my VM (VMware) but its not working there...

this is my code

HotKeySet("{ESC}", "Terminate")
sleep(1500)
 
$a=0
Do
 
;splash 
sleep(1500)
send("4")
sleep(1500)
send("4")
sleep(1500)
send("4")
sleep(1500)
send("4")
 
 
 
 
send("5")
sleep(800)
send("5")
sleep(800)
send("5")
sleep(800)
send("5")
 
 
 
 
 
 
 
$a=$a+1
until $a=50
 
 
Func Terminate()
    Exit
if i send these codes to the SAME client on my own computer it gets executed but whenever i run it on my VM it doesnt work.
(it will send the keys to notepad, but not to the client i would like to)
any idea how come?
how can i solve this?

Share this post


Link to post
Share on other sites
Jos
(it will send the keys to notepad, but not to the client i would like to)
any idea how come?
how can i solve this?

 

if i send these codes to the SAME client on my own computer it gets executed but whenever i run it on my VM it doesnt work.

 

Care to tell us what the client is that isn't working so we might be able to help?

mmm  deja-vu, let's see how this thread ends this time.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
stefan654

ye but i dont think u will know it... its a kal private server.

Share this post


Link to post
Share on other sites
Jos

ye but i dont think u will know it... its a kal private server.

Not sure it is needed that I know what it is other then its gaming related.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Jos

it is, but thats not a problem right?

Maybe you should read our forumrules first before posting here

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.