Sign in to follow this  
Followers 0
florynyus

GUI CPU USAGE

10 posts in this topic

ok everyone i have a litlle problem at my gui , is using like 10, 12% processor and idk why..i mean i use a lot of  Sleep and idk were is the problem

mygui2.au3

Share this post


Link to post
Share on other sites



Problem is this line (probably):

  _GUICtrlIpAddress_Set($hIPAddress, @IPAddress1)

You update GUI in each loop no matter if value changes. Use some global variable and compare @IPAddress1 to that value, if it differs then set @IPAddress1 to that variable and update GUI by _GUICtrlIpAddress_Set()

1 person likes this

Share this post


Link to post
Share on other sites

Problem is this line (probably):

  _GUICtrlIpAddress_Set($hIPAddress, @IPAddress1)

You update GUI in each loop no matter if value changes. Use some global variable and compare @IPAddress1 to that value, if it differs then set @IPAddress1 to that variable and update GUI by _GUICtrlIpAddress_Set()

ok i`ll try

Share this post


Link to post
Share on other sites

Also change set of "If" tests

                   IF GUICtrlRead($combo) = "Chiavetta Internet" And _IsPressed("01", "user32.dll") then
                 IF GUICtrlRead($combo) = "Check Yahoo Statuss" And _IsPressed("01", "user32.dll") then

...

To Switch command
 

1 person likes this

Share this post


Link to post
Share on other sites

Also change set of "If" tests

                   IF GUICtrlRead($combo) = "Chiavetta Internet" And _IsPressed("01", "user32.dll") then

                 IF GUICtrlRead($combo) = "Check Yahoo Statuss" And _IsPressed("01", "user32.dll") then

...

To Switch command

 

ok thx

Share this post


Link to post
Share on other sites

so IF is using so much processor? i`am change right now with switch  and i`ll tell you guys the results

Share this post


Link to post
Share on other sites

ok guys i changed all IF  with Switch and processor usage has decreased at max 5% and then at the end of  while whas Sleep(10)
        WEnd
and i set it to Sleep(150)  Wend and nou i have 0 and max 1%  THX for help guys!!!!

Share this post


Link to post
Share on other sites

BTW, you can remove the GUIGetMsg line from the script, you're not using it anyways so it's just taking up processing time unnecessarily.

1 person likes this

If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

BTW, you can remove the GUIGetMsg line from the script, you're not using it anyways so it's just taking up processing time unnecessarily.

Ok i will thx :D

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

Problem is this line (probably):

  _GUICtrlIpAddress_Set($hIPAddress, @IPAddress1)

You update GUI in each loop no matter if value changes. Use some global variable and compare @IPAddress1 to that value, if it differs then set @IPAddress1 to that variable and update GUI by _GUICtrlIpAddress_Set()

 

Like this:

...
Global $ip_prev

;WHILE =====================================================================================================================================================
while 1
 
  $ip = @IPAddress1
  If $ip <> $ip_prev Then
      ;SET @IPAddress1 TO _GUICtrlIpAddress_Create =============================================================================================================
      _GUICtrlIpAddress_Set($hIPAddress, $ip)
      ;END OF SET ============================================================================================================================================
      $ip_prev = $ip
  EndIf

  ...
 WEnd

And important question:

Does your @IPAddress1 change during running of your script? If not then call _GUICtrlIpAddress_Set($hIPAddress, @IPAddress1) only once before your main loop.

Also remove line with GUIGetMsg() because it's not needed in OnEvent mode.

Edited by Zedna

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0