Sign in to follow this  
Followers 0
wangzhengbo

AU3_RunAsSet unable to unset the RunAs details in AutoItX 3.3.8.1

6 posts in this topic

Test steps:

1. Call AU3_Run("notepad.exe"),

    this will open notepad.

2. Call AU3_RunAsSet("username", "domain", "password")

    and then call AU3_Run("notepad.exe"),

    this will open notepad too.

3. Call AU3_RunAsSet("username", "domain", "wrong password")

    with wrong password, and then call AU3_Run("notepad.exe"),

    this time notepad cannot opened.

4. Call AU3_RunAsSet() to unset the RunAs details,

    and then call AU3_Run("notepad.exe"), this time notepad cannot opened.

I even use AU3_RunAsSet("", "", "") to unset the RunAs details,

but it also can not unset the RunAs details.

Share this post


Link to post
Share on other sites



Please upgrade to the latest release of AutoIt (and AutoItX with it). RunAsSet is a legacy feature which never quite worked as intended. The new release uses RunAs which lets you set the user when you run a process, rather than for all run processes.

Share this post


Link to post
Share on other sites

Please upgrade to the latest release of AutoIt (and AutoItX with it). RunAsSet is a legacy feature which never quite worked as intended. The new release uses RunAs which lets you set the user when you run a process, rather than for all run processes.

 

RunAsSet() can unset RunAs details in AutoItX3.Control. But can not work in AutoItX dll.

Thank you very much.

Share this post


Link to post
Share on other sites

I understand you may have a problem, but you are running an outdated release. If you just upgrade, it won't be a problem.

Share this post


Link to post
Share on other sites

I understand you may have a problem, but you are running an outdated release. If you just upgrade, it won't be a problem.

 

Yes, RunAs worked well in AutoItX 3.3.10.2. I think it's better to have a version(3.3.8.2) to fix the bug with AU3_RunAsSet().

Sorry for my poor english.

Thanks.

Share this post


Link to post
Share on other sites

wangzhengbo,

 

I think it's better to have a version(3.3.8.2) to fix the bug with AU3_RunAsSet()

That is not going to happen. I suggest upgrading and using RunAs as Richard Robertson proposed. :)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0