Sign in to follow this  
Followers 0
jpm

Autoit3-gui (beta) 101.8

13 posts in this topic




I found a solution for returning control ref of the first Focussed button so I upload 101.9

:whistle:

Share this post


Link to post
Share on other sites

where can i get exe's and help for the code sampled above?

:whistle:


Triton

Share this post


Link to post
Share on other sites

where can i get exe's and help for the code sampled above? 

:whistle:

in the thread just above no more 101.8 so minor change so 101.9 replace

topic

OK?

Share this post


Link to post
Share on other sites

I am not completly sure this new version will satisfy every body.

the 101.10 is availailable with the following modification :

  • Focus when minimizing/restoring/maximizing.
  • GuiSetCoord to set current point.
  • Opt("Gui... return previous mode.
  • GuiMsg() returns minimize/restore/maximize change in Opt("GuiNotifyMode", 1). (I am not sure of the coherence with mode,0)
Have a good testing

Download from http://www.hiddensoft.com/fileman/users/jpm/AutoIt3-gui/

Share this post


Link to post
Share on other sites

@jpm: Thanks, all my scripts works now with version 9 so I think they will work with version 10 too :whistle:

wait a minute...

....

yeah, my newest bigger patch-script still works with your new version B)

Ok, I know that was a short testing, but all gui-functions work how they should.

Hopefully it works with other scripts too...(I mean not my scripts...)

Share this post


Link to post
Share on other sites

I am not completly sure this new version will satisfy every body.

the 101.10 is availailable with the following modification :

  • Focus when minimizing/restoring/maximizing.

  • GuiSetCoord to set current point.

  • Opt("Gui... return previous mode.

  • GuiMsg() returns minimize/restore/maximize change in Opt("GuiNotifyMode", 1).  (I am not sure of the coherence with mode,0)
Have a good testing

Download from http://www.hiddensoft.com/fileman/users/jpm/AutoIt3-gui/

Thank you for the change JP. One last thing, can GuiCreate return the HWND of the created window so that users can store that for a safe way to directly access the window? That's obviously very minor, but something I thought that could be useful (I can think of some uses for it at any rate).

Also, I think all Opt's should return the previous state, not just the GUI stuff. Call that a feature request for a future version of AutoIt. This would be especially useful for the parameters that take a time value as you could change the time, then restore the previous time which may or may not be default.

Share this post


Link to post
Share on other sites

@jpm: Thanks, all my scripts works now with version 9 so I think they will work with version 10 too :whistle:

wait a minute...

....

yeah, my newest bigger patch-script still works with your new version  B)

Ok, I know that was a short testing, but all gui-functions work how they should.

Hopefully it works with other scripts too...(I mean not my scripts...)

Good to see that I have not done regression. Now I am in a process of bug correction I think. No more function unless I big windstorm

Thanks for your support.

Share this post


Link to post
Share on other sites

Small little bug, I will check on other computers, but on my winXP machine, the default example script closes strangely:

GUIWrite.au3

Run it, and then just move the mouse back and forth hovering over the buttons to change focus, and it will act like you clicked the close button.

Feature? bug? or just my version? autoit-gui.101.10

Just getting used to having such a nice GUI.


AutoIt3, the MACGYVER Pocket Knife for computers.

Share this post


Link to post
Share on other sites

Small little bug, I will check on other computers, but on my winXP machine, the default example script closes strangely:

GUIWrite.au3

Run it, and then just move the mouse back and forth hovering over the buttons to change focus, and it will act like you clicked the close button.

Feature? bug? or just my version? autoit-gui.101.10

Just getting used to having such a nice GUI.

NO your system is not working strangely.

But to have a quick nonreg on this manual checking of the clicking I put a timeout on the GUIMsg(5) or on the msgBox.

That's yhe reason of the closing when you just move the mouse :whistle:

Share this post


Link to post
Share on other sites

jpm, just a curiosity:

I have downloaded almost every AutoIt-gui version,

Why do you include initially of a script test(I don't remember the name), the line that shows a blank MsgBox? :whistle:

Share this post


Link to post
Share on other sites

jpm, just a curiosity:

I have downloaded almost every AutoIt-gui version,

Why do you include initially of a script test(I don't remember the name), the line that shows a blank MsgBox?  :whistle:

I check all uploaded since the 100.1 non where supposed to display a blank msgbox. I remember a wrong upload displaying something black.

The only thing similar to msgbox is the GuiInputbox.au3 which do the same as the InputBox function of AutoIt3 illustrating the resizing capability of the GUI creation.

Perhaps you download the source, in this case you have the test scripts. Some of them display blank windows.

I hope you have no problem with the current version unless you have to report so the final version will have less bugs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0