Jump to content
Sign in to follow this  
leojarrabi

$CmdLine error in Window Server 2012

Recommended Posts

leojarrabi

We were using Windows Server 2008 before and our autoit is running there just fine. The autoit script is using cmdline variable so it would know what file needs to be processed.

It is run like this in commandline: test.au3 "C:MyTestFile.doc"

But when we tried running the same script on Window Server 2012 we are getting an error "Array variable has incorrect number of subscripts or subscript dimension exceed"

So what I did is I created a much simpler autoit script:

Msgbox(0, "", $CmdLine[1])

It causes the same error.

I changed it to:

Msgbox(0, "", $CmdLine[0])

Then run it in CommandLine test.au3 "C:MyTestFile.doc", it returns 0 instead of "C:MyTestFile.doc"

Any help would be appreciated! Thanks!

 

Share this post


Link to post
Share on other sites
BrewManNH

How exactly are you running the script? Have you tried using it compiled?


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
leojarrabi

No I haven't tried running it in compiled format because we've been changing it a lot because of the classname of the applications we are accessing changes everytime we install it on a different machine.

I have tried your suggestion and compiled it, it works like a charm, though we have to adjust some part of our workflow process to reflect exe instead of au3.

Thank you very much for the help!

I just wonder, why would it run on Server 2008 in au3 format but not on 2012?

Share this post


Link to post
Share on other sites
AdamUL

What does this return?

Msgbox(0, "", $CmdLineRaw)

Also, where are you running the script from?  UAC could be an issue, try running it from an elevated command prompt, and see what you get.    

 

Adam

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×