Jump to content
Sign in to follow this  
seesea

How to call the nonstandard-control(TVirtualStringTree)'s methods?

Recommended Posts

seesea

Hi, I try to deal with a control which "Advanced (Class)" in Au3Info.exe is "[CLASS:TVirtualStringTree; INSTANCE:1]".
It is a nonstandard control, I have used "ControlTreeView" to deal with the standard TreeView controls, but "ControlTreeView" seems does't work well with the "TVirtualStringTree", I tried the "Exists", "GetText", "GetSelected" commands worked well, but the others like "Expand", "Select" didn't work, the @error is 1.

I tried the following functions all worked: ControlFocus, ControlHide, ControlSend, ControlClick.
The following functions didn't work (@error was 1): ControlGetText, ControlTreeView,

Since "ControlTreeView" didn't work, I tried to use "ControlCommand" instead, and get document from https://virtual-treeview.googlecode.com, but many methods in the document I tried were all failed, checked the macro @error was set to 1.

My goal is select an item in the TVirtualStringTree and expand the item´╝îanyone help me? Thanks in advance!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×