Jump to content
Sign in to follow this  
this-is-me

More AutoIt weirdness - ProcessList

Recommended Posts

this-is-me

This time I am not getting a hard crash, but a difference in opinion of whether data returned is complete or not.

#include <Array.au3>
$lst = ProcessList("explorer.exe")
;MsgBox(0, "", $lst[0])
_ArrayDisplay($lst)

When this is run, it shows the array just fine, including item 0. Now uncomment the message box and see that it tells me that the array can't be accessed.
 

"C:Users-----Desktoptest.au3" (3) : ==> Array variable has incorrect number of subscripts or subscript dimension range exceeded.:

MsgBox(0, "", $lst[0])
MsgBox(0, "", ^ ERROR

What is going on here?!

EDIT: For due diligence, I am running Win7 x64, AutoIt 3.3.10.2 Stable, and I have tried this script in 32 and 64 bit modes.

Edited by this-is-me

Who else would I be?

Share this post


Link to post
Share on other sites
this-is-me

Nevermind me. Just not enough sleep.


Who else would I be?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×