Jump to content
Sign in to follow this  
Ghastly_MIB

Install service or enable program in Firewall XP

Recommended Posts

Hey,

It is posible to enable a program in WIndows XP Firewall?

And a other question:

It is posible to install a service to windows?

Or maybe to delete one?

Please help ;)

Share this post


Link to post
Share on other sites

Hey,

It is posible to enable a program in WIndows XP Firewall?

And a other question:

It is posible to install a service to windows?

Or maybe to delete one?

Please help ;)

In answer to your first question lookup netsh, see example below

Run("netsh firewall set allowedprogram winvnc.exe WinVNC ENABLE", "", @SW_HIDE)


Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

So what i should use is this: My name of the program is ReCon.exe behind the windows directory

Run("netsh firewall set allowedprogram ReCon.exe ReCon ENABLE", "", @SW_HIDE)

???

Thanks till so far

Share this post


Link to post
Share on other sites

So what i should use is this: My name of the program is ReCon.exe behind the windows directory

Run("netsh firewall set allowedprogram ReCon.exe ReCon ENABLE", "", @SW_HIDE)

???

Thanks till so far

Bring up a command prompt and type in "netsh firewall set allowedprogram /?" and this will explain the command


Time you enjoyed wasting is not wasted time ......T.S. Elliot
Suspense is worse than disappointment................Robert Burns
God help the man who won't help himself, because no-one else will...........My Grandmother

Share this post


Link to post
Share on other sites

Create or delete services on windows is very easy, there's a windows program that makes it: sc.exe

you can use this program to create or delete a service or query it.

Share this post


Link to post
Share on other sites

Thanks ya all, ;)

But there's one question about starting a service.

I added it succesfully, but it won't start.

It say's that my AutoIt program not respons corectly.

Is there a way to fix this?

If Not, Thanks anyway

Ghastly_MIB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...