Jump to content
Sign in to follow this  
ecelim

ControlSend do not work(also Send)

Recommended Posts

ecelim

Hello,

i want to use the controklick function to the "Enable" Button from this program from microsoft: http://live.sysinternals.com/Autologon.exe

this is a tool to active the autologin at a windows machine, my problem is that i have to use this tool on 600 machines and because this i will do it automaticly with Autoit

i tried it with the [iD:1], with [CLASS:Button; INSTANCE:1], and many other..

i tried it on other tools and there controlklick works! also the Send function with TAB and Enter do not work on the sysinternals autologon tool? i read that autoit only works with windwos conform buttons..maybe the autologon tool is not windows conform

is there any idea what can i do?

Share this post


Link to post
Share on other sites
ecelim

because with the autolgon tool the password is encrypted in the registry..i have to use this tool sorry

any ideas?

Share this post


Link to post
Share on other sites
Jos

I understood that the encrypted password can de decrypted easily.

any ways: Post a script that you use to run autologon so we can see what you are doing and maybe have suggestions on getting it to work.


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
ecelim

this is my code:

Local $envd = EnvGet("TEMP")
Local $envdmit = $envd&"Autologon.exe"
ShellExecute($envdmit,"-accepteula","","open",@SW_SHOW)
Local $hWnd = WinWait("[CLASS:AUTOLOG]", "", 10)
WinActivate("[CLASS:AUTOLOG]")
WinWaitActive("[CLASS:AUTOLOG]")
ControlClick ( "Autologon - Sysinternals", "", 1)
 
and ControlCklick do not work, if it would work i would get a MessageBox Info that autologon is activated or that any field(username or password) is empty..
 
sorry but i have to use this sysinternals tool

Share this post


Link to post
Share on other sites
ecelim

oh wow thanks..with #RequireAdmin the ControlClick and Send work..but why?

Share this post


Link to post
Share on other sites
Jos

oh wow thanks..with #RequireAdmin the ControlClick and Send work..but why?

Because the script needs to run on the same level&credentials as the shelled utility or else it can't control it.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
ecelim

means that, if i use this script on 600 xp clients and they all logged as non admintrator user, the script would not work? if yes, what can i do?

Share this post


Link to post
Share on other sites
Jos

means that, if i use this script on 600 xp clients and they all logged as non admintrator user, the script would not work? if yes, what can i do?

Give it a try on one test users account and see what happens. ;)


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
ecelim

ok i tried it and if i want to use the script i get a window where i can use the administrator, if i fill the administrator infos than it works,

what can i do, to use automaticly the adminstrator?

Share this post


Link to post
Share on other sites
ecelim

the Username, Domain and Password is in the registry, i have a tool to send the autoit script to this 600 computers, than i want to start the script as adminstrator and the Username, Domain and Password comes from the registry, i only have to click enable and close the autologon tool. 

my problem is that i have to start the script automaticly as administrator

Share this post


Link to post
Share on other sites
Jos

the Username, Domain and Password is in the registry, i have a tool to send the autoit script to this 600 computers, than i want to start the script as adminstrator and the Username, Domain and Password comes from the registry, i only have to click enable and close the autologon tool. 

my problem is that i have to start the script automaticly as administrator

But using a runas would shell your script with the wrong credentials updating the wrong user hive.

I can't test it under standard user credentials with #requireAdmin so somebody else will have to help to test this.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×