Sign in to follow this  
Followers 0
kara2004

2 Questions about "Use UPX" with "Compile X64 version"

5 posts in this topic

Q1:

If I use "Use UPX" with "Compile X64 version" the output file is created but not packed (Autoit 3.3.10.2)

Manually compressing the output using upx.exe works fine (as read in older topics, upx previously doesn't work on x64)

Why is this feature not implemented with x64-files?

Q2:

Manually adding upx with

"#AutoIt3Wrapper_Run_After="C:Program files(x86AutoIt3Aut2Exeupx.exe" -9 "%out%""
 

gets the following error:

">Running:"C:Program files(x86AutoIt3Aut2Exeupx.exe" -9 "E:AutoIT_skripteswAutoInstall.exe"
Der Befehl "C:Program" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.
>"C:Program files(x86AutoIt3Aut2Exeupx.exe" -9 "E:AutoIT_skripteswAutoInstall.exe" Ended   rc:1"

What's wrong ?

Thanks

kara2004

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Copy UPX.exe to c:WindowsSysWOW64 or add the path c:Program Files (x86)AutoIt3Aut2Exe to the path environment variable.

Further you can use

#AutoIt3Wrapper_UseUpx=y
#AutoIt3Wrapper_UPX_Parameters=--best --lzma

to enable UPX (requires the SciTE full package).

Br,
UEZ

Edited by UEZ

Please don't send me any personal message and ask for support! I will not reply!

Selection of finest graphical examples at Codepen.io

The own fart smells best!
Her 'sikim hıyar' diyene bir avuç tuz alıp koşma!
¯\_(ツ)_/¯  ٩(●̮̮̃•̃)۶ ٩(-̮̮̃-̃)۶ૐ

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Q1: This is something which still needs to be implemented,   I guess.

Q2: you are missing a ")" in your command line and need enclose the whole line with "":

#AutoIt3Wrapper_Run_After=""C:\Program Files (x86)\AutoIt3\Aut2Exe\upx.exe" -9 "%out%""

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Tested and UPX now works using the latest AU3Wrapper.

The path to UPX in Q2 was correct (error while deleting and rewriting during the tests), but enclosing the whole command in quotes works, too (but is no longer needed)

Thanks a lot for the quick reply and the solutions, Jos

Edited by kara2004

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0