Jump to content
Sign in to follow this  
dannav

AdminRequired compiled script not working when called from another exe

Recommended Posts

dannav

Hi,

I have a very strange situation and hoping someone can explain what is happening.

I have a compiled au3 script (call it script 1) which has #RequireAdmin.  When I run the compiled script directly from a cmd shell, it works as expected. For example on Win 7 with UAC enabled it receive the prompt to continue running.

If I call the same script from another compiled script, script 1 will not run at all.

What is weirder is that I tested the script calling the other script on another machine in a different forest/domain and it worked.

I know the first thing to look for is some GPO or machine setting, but I'm at a loss as I don't see anything in the domain which would block this.

And, again, script one works fine when called from a "regular" cmd shell, but not from a compiled exe with the same arguments.

Anyone have any pointers or suggestions as to what might be the problem or what is happening?

thanks

Share this post


Link to post
Share on other sites
Jos

How do you run Script1 from the second script?

Is the second script running as admin already?

Need more input and preferably some code the demonstrates you problem.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
dannav

The script that calls script 1 is run as a regular account, just like it is done in the cmd shell.  Script 2 calls script 1 using this command

Run("script1.exe", "", @SW_HIDE)

As I mentioned, it works fine in other domains/forests so it is not the script syntax or the fact that script 2 is calling script 1.    As a matter of fact, we've used this compiled script on different forests/domains without issue.  It appears there is something particular about this one domain or machine but I just can't figure out what it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×