Jump to content
Sign in to follow this  
karudish

[FF.au3] Stuck in __FFWaitForRepl

Recommended Posts

karudish

Hi, i did recently a script using FF.au3 functions, and the script, which is an loop of repetitive actions on firefox, it works fine. But after a couple of hours of running the script it gets an error, i mean, i think that mozrepl does stop working after a few hours..

I suspect of that because the output of the script gets full of this:

__FFWaitForRepl ==> Timeout: 30033ms > 30000ms $iTimeOut
.
__FFWaitForRepl ==> Timeout: 30031ms > 30000ms $iTimeOut
.
__FFWaitForRepl ==> Timeout: 30033ms > 30000ms $iTimeOut
.
__FFWaitForRepl ==> Timeout: 30032ms > 30000ms $iTimeOut

__FFWaitForRepl ==> Timeout: 30033ms > 30000ms $iTimeOut

__FFWaitForRepl ==> Timeout: 2090ms > 2000ms $iTimeOut

Is there any problems known about mozrepl and long running scripts? (And yeah, i tried to search but didnt get a solution)

Byw, i already tried the solution of >this topic, still giving the error :(

Share this post


Link to post
Share on other sites
Danp2

@Kovacic

__FFWaitForRepl is an "internal use only" function in FF.au3 that retrieves the results from Mozrepl.

@karudish

I have not experienced this issue, but my script doesn't loop constantly. Can you provide a simple reproducer script?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×