Sign in to follow this  
Followers 0
skipro

exit /stop script

3 posts in this topic

Below is my script. I cannot get it to exit on completion. Tried "exit" and "exitapp". Neither worked. I am new to this.

++++++++++++++++++++++++++++++++++

#region --- Au3Recorder generated code Start (v3.3.9.5 KeyboardLayout=00000409)  ---

#region --- Internal functions Au3Recorder Start ---
Func _Au3RecordSetup()
Opt('WinWaitDelay',100)
Opt('WinDetectHiddenText',1)
Opt('MouseCoordMode',0)
Local $aResult = DllCall('User32.dll', 'int', 'GetKeyboardLayoutNameW', 'wstr', '')
If $aResult[1] <> '00000409' Then
  MsgBox(64, 'Warning', 'Recording has been done under a different Keyboard layout' & @CRLF & '(00000409->' & $aResult[1] & ')')
EndIf

EndFunc

Func _WinWaitActivate($title,$text,$timeout=0)
 WinWait($title,$text,$timeout)
 If Not WinActive($title,$text) Then WinActivate($title,$text)
 WinWaitActive($title,$text,$timeout)
EndFunc

_AU3RecordSetup()
#endregion --- Internal functions Au3Recorder End ---

_WinWaitActivate("RoboForm Password","")
Send("xxxxxxxxxxxx[{ENTER}")
WinWaitActivate("classname=WorkerW","")
#endregion --- Au3Recorder generated code End ---

Share this post


Link to post
Share on other sites



What exactly are you trying to accomplish? It looks like you are trying to automate entering the master password for Roboform. Why would you want to automate that?

Share this post


Link to post
Share on other sites

Try putting a debug line between each line to see where its getting held up.

TrayTip("DEBUG", "Currently executing line number " & @ScriptLineNumber , 5, 1)

Put that between each line and run your script.


C0d3 is P0etry( ͡° ͜ʖ ͡°)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0