Sign in to follow this  
Followers 0
Emerogork

My Task Scheduler stopped talking to Audacity.

11 posts in this topic

Many years ago, I was set up with a few scripts (by Edgar5?) to have the Task Scheduler instruct Audacity to initialize, start recording, pause recording and stop recording based on the time.  It was working fine until I went to clean up the temp files.

I found that the Windows/Temp folder contained 500Meg of 2500 files.  Taking precaution, I created a new folder on a different drive and moved all of the files from the temp folder.  Immediately after this feat, the Task Scheduler stopped talking to Audacity but other scripts still run.

I went through all sorts of attempts to undo the move but nothing seemed to work.  I uninstalled Audacity and reinstalled it but after that it still would not open on order from the TS.  The intersting thing is that when I run Audacity now, I do not see any changes with the contents of the Windows/Temp folder.  In other words, it looks as if Audacity has nothing to do with the temp folder anyway.  Might there be a hidden folder?

The bizzare thing is that the TS stopped talking to Audacity immediately after I moved the temp files.

I am using Win7 and Audacity 2.0.6 which I believe is the latest version.

Even if this has nothing to do with the temp files, what can I do to get it working again.  Interesting, as I write this, I am getting a few ideas to try.  (-:

The au3 file as as follows:

(As a test, I ran only line 12 from the command prompt. Audacity opened.)

 #Region ;**** Directives created by AutoIt3Wrapper_GUI ****
    #AutoIt3Wrapper_Outfile_x64=getStJI.exe
    #EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
    #cs ----------------------------------------------------------------------------
           AutoIt Version: 3.3.6.1
           Author:         edgar5

           Script Function: open Audacity, start recording
    #ce ----------------------------------------------------------------------------

    ; Script Start
    Run ("C:Program FilesAudacity 1.3 Beta (Unicode)audacity.exe")
    ;Run("D:audioAudacitySVNwinUnicode ReleaseAudacity.exe")
    WinWaitActive("Audacity")
    ; WinMenuSelectItem("", "", "Transport", "Record")
    ;since I have not learned about menu item selection I will use keyboard shortcuts
    ;I set Record as <ALT + CTRL + SHIFT + R>
    ;and Stop as <ALT + CTRL + SHIFT + S>
    Send("!^+r+r")
    ; The exclamation point (!) means ALT, the carat (^) means CTRL ,the plus sign (+) means SHIFT

 

Share this post


Link to post
Share on other sites



You are correct.  I posted the wrong code.  That line should have been (as is in the correct file):

   Run ("C:Program Files (x86)Audacityaudacity.exe")

Share this post


Link to post
Share on other sites

UPDATE:

The Task Scheduler is scheduled to run an INI file that calls an au3 file. It looked as if the ini file was not activating.  I placed an Echo Command into the file to see if it is ever written to the screen.  Once in the code, the INI file worked!  The Echo command meant nothing.  I figured that it slowed the system a bit to allow the ini file to complete.  It now has a pause(1000) command installed and it is now working fine.

However, that was only the first problem.

The ini file calls the au3 file but Audacity claims that it does not recognize the file type.  This is the same file that Audacity had been running for the last 2 years.

I realize that this is now probably an Audacity problem but maybe someone here can shed some light onto it.

Share this post


Link to post
Share on other sites

Mia culpa....

I meant .xml files.
Am I old enough to be able enough to blame that on age?

Share this post


Link to post
Share on other sites

Call it what you want or educate me in what I am seeing but here is the file and I can get into it to make changes.  At the end of the code there is a line that calls the au3 file.  When I added the Sleep pause, the code worked.  Granted it did not need to be a full second but in this case it doesn't matter.

- Audacity Init.xml

Share this post


Link to post
Share on other sites

Also, I've noticed that command is capitalized.  Is it case sensitive?

<command> sleep (1000) </command>
<Command>"C:\Gork\__Scheduled Event Scripts\InitializeAudacityB.au3"</Command>

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

There is a new fly in the pudding...

I am also building a computer with Win 8.1 and have installed Audacity.  I exported the settings from Task Scheduler in Win7 machine and imported them in the Win8.1 computer into the Task Scheduler.  I created the folders and stocked them with the supporting files.

I get very similar errors:  When Audacity opened by the TS, I get an error "Could not open file C:_Gorkscheduled".  I don't know if the error statement was truncated or if that is all of the path it is seeing. 

If that isn't enough, I used a DOS 3.1 rule and eleminated all spaces in the path.  This time it found the file but displayed its contents instead.  It shows me the code instead of implimenting it. 

This may also explains why the error path stopped where it did.  Could this be a bug in Audacity?

Edited by Emerogork

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0