Sign in to follow this  
Followers 0
ladesic1

Send function Raw

3 posts in this topic

Hello, I'm having an issue when trying to send a function raw data string that contains special characters. I can send it by putting in exceptions but sometimes it changes the string format, thus why I'm wanting to set up a send command with a flag of raw.

Here is what I need to send exactly like this:

IT5E -s `grep "^5Es" /etc/uucp/Devices | nawk -F " " '{print $1}' | sort -u`

Share this post


Link to post
Share on other sites



ladesic1,

Welcome to the AutoIt forum. :)

But please pay attention to where you post - the "Dev Chat" section where you started this thread is not for general support questions. I have moved it for you, but would ask you to be more careful in future. ;)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Update to question, I'm using .NET to run AutoIt script which I'm tried to send function to multiple putty sessions "same command" I can send the command to one session no problem most of the time fine however, when I select several sessions the command I'm sending the casing get changed or send it to the last one loaded. This leave the remaining sessions in a paused state. Does anyone have any suggestions on how to send a command to multiple putty sessions without the command being changed?

Here is my command I need to send: I believe the 1 is to send it raw

Send("ITapsdp", 1)

Send("{ENTER}")

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0