Sign in to follow this  
Followers 0
jayantsinha7

Error

10 posts in this topic

@@ Trace(5) :    Run(@ComSpec & " /c " & "XYZEnterprise-IndiaDevops.appref-ms" & '"' ,"C:Usersjayant.sinhaAppDataRoamingMicrosoftWindowsStart MenuProgramsXYZ Inc"& '"')
>Error code: 1
 
Please help to fix this issue

Share this post


Link to post
Share on other sites



Hi 

 

I am new to this tool, m trying to run my application with below command. But it is not working. Please help on this

Run(@ComSpec & " /c " & "XYZEnterprise-IndiaDevops.appref-ms" & '"' ,"C:Usersjayant.sinhaAppDataRoamingMicrosoftWindowsStart MenuProgramsXYZ Inc"& '"')

Share this post


Link to post
Share on other sites

jayantsinha7,

In future please start a new thread and do NOT hijack a 9 year old one with an unrelated post. :naughty:

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Try to add ' + " around the path with space:

Run(@ComSpec & " /c " & "XYZEnterprise-IndiaDevops.appref-ms", '"C:\Users\jayant.sinha\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\XYZ Inc\"')

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

Not sure why you didn't open a new thread with your problem, but the shown command doesn't seem to be a executable as there is no ".exe";".com".".bat".

What is the command you type in the CMD window?

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

same answer as in the other thread... The command doesn't look like a executable.

On top of that you need to specify the full path in the first parameter as the second only defines the workdir, not "where to find the program,"!

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

No command m using in CMD.

I apologize for my statement. I was talking about below code

Run(@ComSpec & " /c " & "XYZEnterprise-IndiaDevops.appref-ms" & '"' ,"C:Usersjayant.sinhaAppDataRoamingMicrosoftWindowsStart MenuProgramsXYZ Inc"& '"')

i want to run my application with the help of above code.

But is is not working.

Please help.

Share this post


Link to post
Share on other sites

Hi All,

 

Sorry guys, I am very new in this tool. Not even worked on windows automation tool ever. 

I am just trying to gain and learn from example and grabbing code from there and using.

below is my code:-

#include <Constants.au3>
Run("C:Usersjayant.sinhaAppDataRoamingMicrosoftWindowsStart MenuProgramsXYZ IncXYZEnterprise-IndiaDevops.appref-ms")
WinWaitActive("[CLASS:WindowsForms10.Window.8.app.0.26ea292_r11_ad1]")
Sleep(2000)
; Now quit by sending a "close" request to the calculator window using the classname
WinClose("[CLASS:WindowsForms10.Window.8.app.0.26ea292_r11_ad1]")
; Now wait for the calculator to close before continuing
WinWaitClose("[CLASS:WindowsForms10.Window.8.app.0.26ea292_r11_ad1]")
ConsoleWrite("Completed")
 
 
Output:-
>Running:(3.3.12.0):C:Program FilesAutoIt3autoit3.exe "C:\Program Files\AutoIt3\Examples\testNew.au3"    
--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
 
It is not working so i need help.
 
 

Share this post


Link to post
Share on other sites

Multiple threads merged. :)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Hello and welcome to the autoit forums!

Please next time post your code by clicking on the Code command (or what it is :) ) on the editor (bluish image with a white A)

I'm a new user too but gained so much help from these forums that now I try to give something back.

As Master Jos pointed out it doesn't seems to be an .exe file so this could be the problem, but to me it seems like your script is running just doesnt do anything.

I recommend adding Opt("TrayIconDebug", 1) to all of your scripts because it helped me a lot (still does) what it does is that show a trayicon which tells you "where" is your script allowing you to see where the cript is stuck.

It just an idea but have you tried adding .exe or what is the file format to the end? (if this isnt a valid idea the older members should tell you that don't listen to me :) )

Have you tried with Geri1983's code?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0