Jump to content
Sign in to follow this  
khwong

PowerBuilder Application Execution Error (R0003)

Recommended Posts

khwong

Hi,

I have created a script with AutoIT v3.3.8.1. Once created i tried on different PC/laptop, most of them can be ran successfully within any problem, but when I run on Lenovo ThinkPad New X1 Carbon Ultrabook, an error "Application terminated. Error:Array boundary exceeded (PowerBuilder Application Execution Error (R0003))" is displayed. 

I have tried on several X1 Carbon laptop, all of them can reproduce the issue, does anyone know what is the problem is?

will the following scripts produce the error?

"$objWMIService = ObjGet('winmgmts:{impersonationLevel=impersonate}!' & $strComputer & "rootcimv2")
 $colChassis = $objWMIService.ExecQuery("Select * from Win32_SystemEnclosure")
 For $objChassis in $colChassis
 For $strChassisType in $objChassis.ChassisTypes"

Share this post


Link to post
Share on other sites
JLogan3o13

Obviously there is something of a language barrier here. If you are having problems with a PowerBuilder application, you need to post the code for that script. As the code you did post is a simple WMI call, it should not cause a problem, but if you want to know for sure - try it.

Again, as far as your PowerBuilder script and its issues, we can't assist if you don't post your code.


√-1 2^3 ∑ π, and it was delicious!

How to get your question answered on this forum!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×