Sign in to follow this  
Followers 0
pcjunki

combo scrolling

4 posts in this topic

I'm having some issues with one of my combo boxes scrolling.

I have allot of data populated in the combo box, and I need a scroll bar to scroll through and choose.

on my guicreate I'm using  

$Form1 = GUICreate("my stuff", 1001, 724, 147, 131, BitOR($GUI_SS_DEFAULT_GUI, $WS_MAXIMIZEBOX, $WS_SIZEBOX, $WS_THICKFRAME, $WS_TABSTOP, $WS_EX_WINDOWEDGE))

then my combo box is

$input1 = GUICtrlCreateCombo("", 216, 107, 233, 25, BitOR($CBS_DROPDOWN, $CBS_AUTOHSCROLL))

could the styles I'm using in the guicreate messing up the styles in the combo box?

(I have all my includes programmed in as well)

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

pcjunki,

Use $WS_VSCROLL in place of $CBS_AUTOHSCROLL. ;)

M23

Edit: And I came up with the same answer again! :D

Edited by Melba23

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

yup... that's how I fixed it, was reading your other post

:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0