Sign in to follow this  
Followers 0
TrackGram

Spaces and Commas in MSI String

3 posts in this topic

I have a MSI command that has a space and some commas, they are required by the MSI command. How do i pass the space and commas in the string to the MSI with out AutoIT getting confused? There must be a way to tell AutoIT to pass the parameter/string along.

String -

RunWait ("Msiexec.exe /i pdfDocs4-1-600-123-x86.msi /qn DEFAULTPDFAPP=1 INSTALLFOLDER="C:Program FilesDocsCorppdfDocs" ADDLOCAL=Capensys,Core,DMContextMenu,OfficeAddins,OutlookAddin,ShellIntegration,OCRDESKTOP")

Program Files has a space and the ADDLOCAL string has many commas. I cannot get this string to work. what is the secret? 

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Encase the commands that have spaces/commas in double quotes.

Edit:

The quotes were off, seems like you already attempted what I suggested above.

I'm not sure the commas matter, but if they do, just do what I did for the "program files" one with the commas if need be:

RunWait ("Msiexec.exe /i pdfDocs4-1-600-123-x86.msi /qn DEFAULTPDFAPP=1 INSTALLFOLDER=""C:\Program Files\DocsCorp\pdfDocs"" ADDLOCAL=Capensys,Core,DMContextMenu,OfficeAddins,OutlookAddin,ShellIntegration,OCRDESKTOP")
Edited by SmOke_N

[center]Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.[/center]

Share this post


Link to post
Share on other sites

OMG - well, thank you for this SmOke_N. I think you slammed it.  So far initial testing is working.  I did try double quotes on the c:program files argument and on the ADDLOCAL argument. I also tried doing double quotes only on the c:program files argument.  I think this is working.  I need to do a bit more testing in a production setting. I will reply again letting you know if this in fact is 100 percent.  Thank you for the response. I really appreciate your help with this, i know how valuable peoples time is.  Your expertise makes a difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0