Sign in to follow this  
Followers 0
square65

Scite Window Position not saving

6 posts in this topic

#1 ·  Posted (edited)

Scite doesn't save its window position when you close it.

How do I get it to?

I read that you can add the line

save.position

To the global settings file but I don't know where that file is.

I scanned my hard drive for a SciteGlobal.* but didn't find anything.

 

Also, I opened the file manually, via Scite itself and added the line in question and it changed nothing.

Also tried save.position = 1 and save.position = true, save.position 1, and save.position true. No dice.

Edited by square65

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

That is one of the things I tried initially and it did not work.

What could the issue be then? I haven't messed with any settings. Installed Scite to the default directory. Have a very standard Windows 7 installation.

I should mention. The retarded default opening dimensions (squeezed vertically to maybe 100 pixels wide and 75% of the monitor's height tall are the state it was put in once by a script I wrote going haywire and clicking and dragging all over my desktop.

But why should that now be the only state it can possibly be in when I open it?

Funny thing is that script I wrote, which has about 1000 lines of code now is far more robust than Scite itself, given this annoyance.

Edited by square65

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Global options or Local options?  There is a difference.  If you put save.position=1 above save.position=0 then the one that is below will take precedence.  Make sure that isn't the case.

Have you tried to manually change the size and position of the SciTE window?

Check out these options and tell us what they are:

position.left
position.top
position.width
position.height
Edited by jaberwacky

Share this post


Link to post
Share on other sites

Well I've been maximizing, minimizing, and moving to left half of monitor with windows hotkeys.

I just dragged it to resize it and that worked.

Asinine.

To say the least.

Share this post


Link to post
Share on other sites

Thanks btw

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0