Jump to content

Help with obfuscator needed


Go to solution Solved by Jos,

Recommended Posts

Hi,

I need to see which line number corresponds to an error in my script. Looking at multiple threads I find that this can be done with obfuscator options.

I am using version 3.3.8.1.

I set the following in the script:

#AutoIt3Wrapper_UseX64=Y
#AutoIt3Wrapper_Run_Obfuscator=y
#Obfuscator_Parameters=/mergeonly
#Obfuscator_Ignore_Funcs=_Func_1,_Func_2,_Func_3,_Func_4

Then I press F7 to compile.

The console shows "Running Obfuscator (1.0.30.4)  from:C:Program Files (x86)AutoIt3SciTEObfuscator cmdline:"

Then the error comes, both in console and in a popup. The error that pops up is :

"Can't open file C:Program Files (x86)AutoIt3SciTEObfuscatorObfuscator.Log"

It can be seen in the error that the path to the logfile is the problem (it has "" where "" should be) but I don't know where to set this, I am searching for this in the AutoIT folder

Then if I try to continue anyway I get an error like : "Error : couldn't open input file: E:<folder><folder>Working_SourcesnewSetBackupDrive_Obfuscated.au3".

So of course aut2exe can't compile anything because nothing is created. I'm looking in Autoit3wrapper.au3 and I think the issue is in the $ObfuscatorCmdLine but I can't find where that gets created?

Anyone know how I can fix this? It happens if I comment out the wrapper setting to use x64 too.

(Edit: if I run obfuscator from the command line, the same error comes - "Can't open file C:Program Files (x86)AutoIt3SciTEObfuscatorObfuscator.Log")

Edited by ModemJunki

Always carry a towel.

Link to post
Share on other sites
  • Developers
  • Solution

Are you sure you have write access to the log file?

Maybe you should upgrade to the newer setup with au3strpper which isnlt using the " program files" directory anymore for its user files and logs.

Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Link to post
Share on other sites

Oops! Access to the logfile folder was it - I uninstalled and reinstalled AutoIT to a different folder, now it works, thank you.

At the moment I have to stick to 3.3.8.1 until I have time to migrate.

Thanks, Jos!

Edited by ModemJunki

Always carry a towel.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...