Jump to content
Sign in to follow this  
Javik

ConsoleWrite and CUI .. what am I missing?

Recommended Posts

Javik

What's wrong here:

(Weird, the forum deleted my post below the code block. This wasn't meant to be so brief a posting.)

#AutoIt3Wrapper_Change2CUI=y
consolewrite ("It works!" + @CRLF)
Edited by Javik

Share this post


Link to post
Share on other sites
Javik

Eh, I cannot edit that post now, can't move cursor below the code block, can not see raw post formatting... ???

Anyway, that fails to work like I'd expect with the Windows 7 64bit SP1 command prompt. The console output is "0" .... which is unexpected.

Edited by Javik

Share this post


Link to post
Share on other sites
BrewManNH

Use & and not + to concatenate the 2 strings.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
Javik

Ah, okay that works as expected. Thank you.

I'm doing some more digging in forum, I see a reference to #pragma compile(Console, true)

But the code works correctly without that pragma option, if I change the + to &. Hmmm.

Using AutoIT 3.8.8.1  1/8/2013

Share this post


Link to post
Share on other sites
Jos

 

(Weird, the forum deleted my post below the code block. This wasn't meant to be so brief a posting.)

 

Guess the forum upgrade has introduced this as I have seen other mentioning this as well.

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×