Jump to content
bohni

Aut2Exe crashes with memory allocation error

Recommended Posts

bohni

Hi,

I am using autoIt for several yeary now to create an installer for my software.

Today I tried to build one for a debug version of the software.

Aut2Exe crashes and showed a dialog with a "memory allocation error".

Somehow the debug build seems to hit some limit.

The Installer is normally about 700MB big .. is there a known limit near 1GB which I might hit?

I was able to reproduce this problem, ie. it does not look like a random bug.

I was using 3.3.8.1

Edited by bohni

Share this post


Link to post
Share on other sites
TheDcoder

I think you had <700 MB Ram free when this happen, I don't know much about it...

Try changing "FileInstall Compression: " to "Lowest" when compiling, TD ;)


AutoIt.4.Life Clubrooms - Life is like a Donut (secret key)

Spoiler

My contributions to the AutoIt Community

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) mean to do that to anybody!!!

3fHNZJ.gif

PLEASE JOIN ##AutoIt AND HELP THE IRC AUTOIT COMMUNITY!

Share this post


Link to post
Share on other sites
bohni

No I had several GB free when this happened.

Share this post


Link to post
Share on other sites
TheDcoder

Then its hard to identify the problem, please provide much details as possible. In the meanwhile try running MemTest86

TD :)


AutoIt.4.Life Clubrooms - Life is like a Donut (secret key)

Spoiler

My contributions to the AutoIt Community

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) mean to do that to anybody!!!

3fHNZJ.gif

PLEASE JOIN ##AutoIt AND HELP THE IRC AUTOIT COMMUNITY!

Share this post


Link to post
Share on other sites
Zedna

What OS do you have?

There was error in Aut2Exe fixed in version 3.3.10.2 on XP SP2:

 

(30th December, 2013) (Release)

Aut2Exe:

  • Fixed #2580: Aut2Exe failing to run multiple times on Windows XP prior to SP3.

***

Try it with latest version of AutoIt ...

Edited by Zedna

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×