Jump to content
Erwan37

MSPaint madness

Recommended Posts

Erwan37

Hi, madness, yes. Because my frustration level is reaching the top. I've been trying to do something quite simple during the past 4 hours and I couldn't get through it. So I'm here hoping that someone would be smarter than me, it ain't hard anyway.

Goal :   painting a dot in Microsoft Paint ...while another window is in front of it.

Yes, nothing else, once I'm done with this I can go on.

a ) start Paint

b ) put an explorer window that cover it all

c) click in the middle of the explorer window, minimize it and tadaaaa a dot has magically appeared behind, in paint.

Now for more infos :

I'm not new to AutoIt, been using it for years, for example, I know for a fact that if I was under Windows XP with the good old Paint and old Autoit this would be a piece of cake. Yes, I know about ControlClick, SendMessage, and other methods to achieve that, and yes I've been reading the helpfile (not that I really need to since I'm more than familiar with those). Yes I know about AutoIt window Info (x86, x64, both give me the same infos (prolly because paint is 32b)) and yes I've been trying all combinations with it, using CLASS, ID, CLASSNN, whatever.. nothing works. I've tried defining the click as 'left' or 'primary', no success.

I'm under Windows7x64, Paint 6.1. , AutoIt 3.3.12.0 and on the breach of throwing the whole computer through window. (when I'm facing hard issues and spend hours to answer them it's fine, but when it's something that looks THAT simple that stops me it's a real pain)

Thanks to anyone wanting to help and contribute saving my computer :)

 

N.B. :

the control info displayed for the board area in Paint on my system is Afx:00000000FFA50000:8   , I've tried using other (parents) control though, but it didn't work either.

Yes I've been searching this forum, googling, found numerous topic and answers to this.. none of them works, thus why i'm posting a new thread.

 

 

Edited by Erwan37

Share this post


Link to post
Share on other sites
l3ill

Hi,

And welcome to the Forum.

Would you mind showing us the code you have been working with?

Edit:

This works fine no matter what window is in front of it...

ControlClick("Untitled - Paint", "",  "[CLASS:Afx:d50000:8; INSTANCE:1]", "left", 1, 450, 330)

 

Edited by l3ill

Share this post


Link to post
Share on other sites
Erwan37

Nothing more than your line of code which does not .. work on my system.. crazy no ? (of course I used the correct title, using a handle gotten with WinGetHandle, verified that it was the right one using WinMove) (I also used the real title like you, except it's in my language) but apart from that, and using your CLASS number or mine (the one showed by autoit info)... it doesn't work

I guess the inner issue is not about how to do it because it's obvious it's what you said, what I knew, and what I've been reading all over many topics.. but why it doesn't work on my system but I've been thinking of many things and still cannot find an answer to that.

 

note : as I named my topic, it's specific about Paint, I've been using controlclick on other apps (notepad for instance) and it works

Edited by Erwan37

Share this post


Link to post
Share on other sites
Erwan37

well you posted that 2nd message before I could see the other one.. I guess that's called cross posting.
 About previous accounts ? since it's dating back months / years I have no clue about the login infos so what could I do. The one still present in Firefox's passwords is linked to an email** that I don't even have an access to anymore since.. well... the password has been long forgotten as well. (had no idea it was 4 btw.. on that IP probably but you could add more when I was living at other places tbh.. I'm posting like once a year or two so yeah i'm not really part of your community, if that means I'm not entitled to ask questions, sorry for posting that topic)

Apart from spying this kind of stuff, I'd be interested if you had any idea on the topic. I edited the previous message to avoid a "re-install autoit" or "install latest version" suggestion (that I already thought about), but imo it's irrelevant since it's working on Notepad for instance. I simply don't get the Paint issue.

 

** I tried login in with it since Firefox had it remember (unlike me) and it failed so this is where I made a new one, I later realised that was because the login was asking for the "display name" and firefox had the "email" saved and it wasn't working logging with it. (I realised because after making that new account it wasn't working either.. until I noticed the difference in the way that forum is treating e-mail / display name, I've used other forums where you could use both to log in

 

Edited by Erwan37

Share this post


Link to post
Share on other sites
SadBunny

Well, it's not spying if you're a forum admin, it's just looking up some usage data ;)

l3ill's code works fine for me as well, no matter what I place in front of the paint window (of course I'm replacing the mspaint window class code by my own). I'm on Windows 8.1. So maybe it helps if you show a reproducer like l3ill suggested?


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites
Erwan37

 

$hW = WinGetHandle("Sans titre - Paint")
WinMove($hW, '', 20, 20)
Sleep(1000)
ControlClick("Sans titre - Paint", "",  "[Afx:00000000FF6A0000:8; INSTANCE:1]", "left", 1, 100, 100)

 

as I said previously, there's no more code than what |3|ill suggested.. except getting the handle and moving the window to check I'm on the right one. The class code differs. But with him, mine or any other I could find with Autoit Info, I still can't paint a dot. (I changed brush size to big to be sure to notice it so it's not a pixel either)

 

Edited by Erwan37

Share this post


Link to post
Share on other sites
l3ill

 

ControlClick("Sans titre - Paint", "",  "[CLASS:Afx:00000000FF6A0000:8; INSTANCE:1]", "left", 1, 100, 100)
                                     missing class identifier

 

Edit: also FYI this number changes every time you close and open the prog

Edited by l3ill

Share this post


Link to post
Share on other sites
Jos

Apart from spying this kind of stuff, I'd be interested if you had any idea on the topic.

​Guess you haven't changed approach in life yet since your last thread posted back in February.
So, wish you luck with your endeavours and hope we don't have to moderate as we had to is the past, but don't count on my time to help. ;)

Jos

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
Erwan37

 

ControlClick("Sans titre - Paint", "",  "[CLASS:Afx:00000000FF6A0000:8; INSTANCE:1]", "left", 1, 100, 100)
                                     missing class identifier

 

Edit: also FYI this number changes every time you close and open the prog

Damn, a typo that could led you thinking it was that.. sorry for that. So yeah, of course CLASS should be there (and is there in my script). And it's not working either. And no, that number doesn't change.. I just tested it.

Share this post


Link to post
Share on other sites
Erwan37

​Guess you haven't changed approach in life yet since your last thread posted back in February.So, wish you luck with your endeavours and hope we don't have to moderate as we had to is the past, but don't count on my time to help. ;)

Jos

​fine, whatever. Hopefully Melba23 will pass by and share his kindness and knowledge because I like that person, he's been helpful and sympathetic. Your time worthes more than that I agree. Have a nice day.

 

Share this post


Link to post
Share on other sites
Melba23

Erwan,

Hopefully Melba23 will pass by

Had I passed by earlier you would not still be here. But as Jos has decided to let you remain, so will I.  But I very strongly suggest that you very quickly lose the attitude that got you banned last time and which judging by this thread is still there.

 I like that person, he's been helpful and sympathetic

Please do not bother to tell me that you have changed your mind.... 

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites
Erwan37
correction : yes, that number changes every time. No idea why my test showed the same. When I checked again I could see that behavior. Unfortunately this doesn't solve the fact the dot doesn't appear.
 

^ relating to one of my previous message (can't get how those quotes work, it's just all messed up and I have hard time formatting that correctly, didn't find how to display the actual code of the message either)

 

answer to M23 :

​Well, I have no clue what you're talking about but I know Jos briefed you since he told me.. I don't remember any argument with you, on the opposite, and as previously said I had you in mind as kind, helpful & knowledgeable. I don't even get what my thread has to raise such animosity. I was trying to get some help after hours of struggling, had put a bit of humor inside (the computer through the window) and you guys seem to be really serious about all that. Fine, I'll take note from this and will just put some code lines, simple questions in the future. I also note that redemption isn't allowed here. Anyway, sorry for that off-topic but I'm kinda shocked by all these reactions.

I still thank |3|ill for having tried to help, it didn't led to an answer though but I guess I'll find it while not searching as most of the time.

Edited by Erwan37

Share this post


Link to post
Share on other sites
Melba23

Erwan37,

Well, I have no clue what you're talking about

Then let me remind you.

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites
argumentum

... to AutoIt, been using it for years, for example, I know for a fact that if I was under Windows XP with the good old Paint and old Autoit this would be a piece of cake.

​I'll tell you what. You write the complete working code ( use a virtual PC if you have to ), and I'll "translate" the code for Windows7x64, Paint 6.1. , AutoIt 3.3.12.0

Share this post


Link to post
Share on other sites
SadBunny

Tried it on W7, still works fine.


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×