Sign in to follow this  
Followers 0
Jasio

Script not acting right

5 posts in this topic

It's supposed to hit tab 35 times, and it does on the first part, then on the second series it stops around 33 and hits enter.. is there somthing wrong with the code?

AutoItSetOption ( "SendKeyDelay", 40 )
WinActivate("(SFGC) Galactic Conquest - Microsoft Internet Explorer", "")
Sleep("3000")
Send("{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{

TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}")
Sleep("1000")
Send("{ENTER}")
WinActivate("(SFGC) Galactic Conquest - Microsoft Internet Explorer", "")
Sleep("3000")
Send("{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{

TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}")
Sleep("1000")
Send("{ENTER}")
WinActivate("(SFGC) Galactic Conquest - Microsoft Internet Explorer", "")
Sleep("160000")

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Please try the suggestions here...

Also, I'm not familiar with what you're automating, but if it's running in Internet Explorer, you may be able to use DaleHolm's IE.au3 UDF.

Edit: @Jasio: I got your PM. I figured it was a glitch in the system. Let me know how it goes.

Edited by Skruge

[font="Tahoma"]"Tougher than the toughies and smarter than the smarties"[/font]

Share this post


Link to post
Share on other sites

It's supposed to hit tab 35 times, and it does on the first part, then on the second series it stops around 33 and hits enter.. is there somthing wrong with the code?

AutoItSetOption ( "SendKeyDelay", 40 )
WinActivate("(SFGC) Galactic Conquest - Microsoft Internet Explorer", "")
Sleep("3000")
Send("{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{

TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}")
Sleep("1000")
Send("{ENTER}")
WinActivate("(SFGC) Galactic Conquest - Microsoft Internet Explorer", "")
Sleep("3000")
Send("{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{

TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}{TAB}")
Sleep("1000")
Send("{ENTER}")
WinActivate("(SFGC) Galactic Conquest - Microsoft Internet Explorer", "")
Sleep("160000")
Well for starters why not use a for loop to press tab instead of just listing it. That would take out any possiblity of a counting error. Also I am not even sure you can send that many things with one send statement. Atleast break it up into chunks of maybe 5 tabs each.

Share this post


Link to post
Share on other sites

I could swear that you already created another thread for this question...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0