Jump to content
WarriorNetwork

Right Click Edit Opens in Notepad, Missing all right click Commands (Win 8.1) [Solution]

Recommended Posts

WarriorNetwork

So after downloading a program run by AutoIt, and admittedly prior to installing AutoIt, I chose to edit the script and without thinking  I selected NotePad as the default program for this action. I didn't think much of it until I downloaded AutoIt v3 and SciTE script editor and realized I was missing some pretty important functions in my right click menu (Compile Script, Run Script, Edit Script, Tidy, etc..).

I racked my brain on how to solve this issue with Windows 8.1. I searched this forum up and down, tried Google and even went beyond the 1st page of its search results!! Everywhere I looked there were solutions for XP, Vista and Win7. But not a single working (for me) solution for Windows 8.1. So this is what I tried and what eventually got me working.

I went through the Control Panel and changed all file associations of .au3 to open with AutoIt3.exe.

I uninstalled all programs, I reinstalled running them as administrator.

I tried using the Registry Check/Fix in SciTE and followed it's instructions on removing the "User Control" registry and such.

Tried uninstalling and reinstalling again. But all to no avail.

Eventually I was at a breaking point and thought I was going to have to reformat my computer in order to get a clean install. It was at this point that I decided to try a last ditch attempt with the thought process of, "It can't get any worse if I am going to reformat anyway." So I proceeded to uninstall all AutoIt software and SciTE. I scanned my computer for any and all .au3 files and removed them. I then went back into the Registry Editor and used the fantastic Find (Ctrl + F) feature and searched for .au3. Every single instance (and there were many) where .au3 populated I proceeded to delete. This process took a little while, but it was faster than formatting and reinstalling Windows 8.1. When Find could no longer find any instances of .au3, I rebooted the computer. Upon logging in I proceeded to install AutoItv3 as an administrator and the same for SciTE. Once everything was done installing, and before even attempting the Right Click I rebooted the computer again. 

Once Windows restarted I redownloaded the .au3 program I wanted to run/edit the first go around. With my (left hands) fingers crossed, I executed a right click on the .au3. Success! There were all of my shell commands I was so desperately searching for. A wave of relief quickly washed over me and I felt the tension in my shoulder release a little.

So I decided to come here to the forums and share my experiences in the hopes that if someone else pulls a noob move like I did, they won't beat themselves up for hours searching for the answer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×