Jump to content
wklw2005

ControlSetText help

Recommended Posts

wklw2005
ControlSetText ( "CAESAR II 2014 - InstallShield Wizard", "&User Name:", 17049, "Username")
Sleep(100)
ControlSetText ( "CAESAR II 2014 - InstallShield Wizard", "&Organization:", 17043, "Organization")
Sleep(100)
ControlSetText ( "CAESAR II 2014 - InstallShield Wizard", "&Serial Number:", ?, "123456789")
Sleep(100)

 

 

I am filling in some input boxes during an install. I just noticed that the Serial Number input box does not have an ID. Can someone please point me in the right direction? The other input boxes are working fine and the text is sending.

 

inputbox.jpg

Edited by wklw2005

Share this post


Link to post
Share on other sites
SupaNewb
ControlSetText("CAESAR II 2014 - InstallShield Wizard", "&Serial Number:","[CLASS:Edit; INSTANCE:1]", "123456789")
  • Like 1

Share this post


Link to post
Share on other sites
wklw2005
ControlSetText("CAESAR II 2014 - InstallShield Wizard", "&Serial Number:","[CLASS:Edit; INSTANCE:1]", "123456789")

Thanks SupaNewb that worked great....

Share this post


Link to post
Share on other sites
wklw2005

I am not sure what's happening here, I add the serial number using the ControlSetText and then get this little beauty!!!! If I delete one number, retype it and hit next it works. I can't find a way to automate that. Help....

Invalid.jpg

Share this post


Link to post
Share on other sites
SupaNewb
;taking a wild guess here lol.
ControlFocus("CAESAR II 2014 - InstallShield Wizard", "&Serial Number:","[CLASS:Edit; INSTANCE:1]")
Sleep(100)
ControlSend("CAESAR II 2014 - InstallShield Wizard", "&Serial Number:","[CLASS:Edit; INSTANCE:1]", "123456789")

;OR

ControlFocus("CAESAR II 2014 - InstallShield Wizard", "&Serial Number:","[CLASS:Edit; INSTANCE:1]")
Sleep(100)
Send("{NUMPAD1}{NUMPAD2}{NUMPAD3}{NUMPAD4}{NUMPAD5}{NUMPAD6}{NUMPAD7}{NUMPAD8}{NUMPAD9}{ENTER}")

 

  • Like 1

Share this post


Link to post
Share on other sites
wklw2005

Your the best SupaNewb, thank you very much!!!!

  • Like 1

Share this post


Link to post
Share on other sites
wklw2005
ControlClick("CAESAR II Configuration Editor", "Main CommandBar","[CLASS:XTPToolBar; INSTANCE:1]", "left", 1, 21, 11)

 I have never run into so many issues with a software package in my life... HA HA  I am not able to create an ISS file so I am using control click for this install. Right before it's complete I get this toolbar, You hit save and it closes... the script continues and completes. I don't see an ID for the save button and the control click is not working.... What I am doing wrong? Please help!!!!

Untitled.jpg

Toolbar.jpg

Share this post


Link to post
Share on other sites
SupaNewb

This post might help you:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×