DarkOnyx

Send keys not working in Windows Dialogue

3 posts in this topic

Forgive if this question has been asked before, I am sure it has, but I've done a lot of looking around and I can't find an answer to what I am dealing with.

Autoit send keys do not seem to work in Windows dialogues.  Whereas before let's say I needed to press enter on a screen that said "Windows Permissions" it would be:

Winwaitactive ("Windows Permissions")
Winactivate (("Windows Permissions")
Send ("{ENTER}")

It can recognize the window and even make it active.  When it's time to hit the enter key to get rid of the annoying window... it bails.  Nothing happens.  I've used ControlSend and such and that doesn't work either.

Anybody else run into this?  This was working on Windows 7.  Thanks.

Share this post


Link to post
Share on other sites



Disable UAC and run your script as admin. You are not allowed to talk about bypassing security on here though. You will have to manually disable the UAC before using the script I think.


Get Scite to add a popup when you use a 3rd party UDF -> http://www.autoitscript.com/autoit3/scite/docs/SciTE4AutoIt3/user-calltip-manager.html

Share this post


Link to post
Share on other sites

Perfect.

That's exactly what it was THANKS A TON!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now