elguapo159

Nagios-autoit-interactive session

2 posts in this topic

Hi all,

We have a few applications we want to test if they still function from the user point of view. We started out for 1 application and created an autoIT script for it by hand. If we run the script, it works without issues. If we force it to fail, it takes a screenshot of the error and stops the script like it should. The issue we have is we cant run it via Nagios without user interaction. All screenshots end up black and we can't get our output back. We use a windows8.1 as remote test machine.

We have already enabled the option on the nsclient on the windows test machine "Allow service to interact with desktop". This doesn't fix the issue. After some more research we also had to change something in the registry. Path: Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Windows change NoInteractiveServices with value 1 to 0. This overruled the value on service (this was change by Microsoft). But still no fix.

We have also tried to approach it differently, using psexec to call the autoIT exe. But even that one didn't fix the issue.

I have been working at this for a few days now without a fix. Has somebody tried this before? Does someone have a solution for this? If you have an idea to get this to work, please let me know.

Thanks in advance,

E

Share this post


Link to post
Share on other sites



Has someone an idea on how to fix this please? Or maybe just a pointer to where i can look?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now