edpatterson

Newly compiles scripts no longer working

4 posts in this topic

Scripts compile but will not run, recent happening

Scripts I compiled more that a month ago work just fine. The exact same scripts compiled on the same machines now fail.

I created an empty form with Koda, ran the form (F10), it opened in Scite, pressing F5 caused the form to run.

I saved the script as testing123.au3, compiled it (F7), no errors, ran the newly created exe, hourglass. Wait, wait, wait, notta. Tasklist shows 3 Testing123.exe processes.

Killtask /im testing123.exe /f /t
Kills all 3 processes
Tasklist shows the same 3 processes running
Repeating the taskkill command reports the processes do not exist
A reboot is needed to make the processes go away

Same tests performed on 2 different computers

Ideas?

The only way I can get the GUI to show is via the F5 key in Scite.


Windows 10 - recent Windows updates.
ScITE 3.4.4
Aut2exe 3.3.12.0

 

Share this post


Link to post
Share on other sites



edpatterson,

Welcome to the AutoIt forums.

Have you tried disabling your AV before trying to run the script?

M23

 


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

I can confirm the same sort of issue, but AFAIK it's not an AutoIt-only issue: it's happening for me in scripts compiled also with AutoHotkey and RapidBatch. The compiled scripts that no longer work all have in common the use of Windows GUI elements (e.g. InputBox or MsgBox). Other compiled scripts that do not use the GUI seem to work just fine.

When I disabled my AV (Avast) the scripts worked again, so it's something that probably has to do with the AV... although I'm not sure exactly how: Avast has a "sandbox" mode that supposedly permits the execution of suspicious programs, but my compiled scripts didn't work in sandbox mode either. Also, when I scanned the compiled scripts' *exe files, Avast detected no threats. 

I've also checked with Windows (both W 7 and W 10), and the compiled scripts programs appear as Incompatible Applications", but trying to run them as a Windows XP program (for example) doesn't solve the problem.

All these scripts, when launched from an interpreter (AutoIt, AutoHotkey or RapidBatch) all work just fine.

I've been able to solve the issue, at least temporarily, by whitelisting in Avast the folder where I keep the compiled scripts.

Edited by RSchiaffino
Additional information (provisional solution)

Share this post


Link to post
Share on other sites

If it means anything, I have had the same on Windows 10 and/or McAfee.  Scripts just die with no apparent reason.  No system feedback.


Skysnake

Why is the snake in the sky?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now