VAN0

SciTE ignores SciTEUser.properties

4 posts in this topic

Hello.

I'm using latest portable SciTE 3.6.0 on Windows 10 x64

It's located in E:\Program Files\Autoit3\SciTE\

All .properties files are located in the same directory as SciTE.exe file

It works fine when SciTE.exe executed directly from that directory, however when I start it from a shortcut which is located outside of E:\Program Files\Autoit3\ directory (quick launch) it ignores SciTEUser.properties file and attempting load it from %userprofile%\appdata\local\AutoIt v3\ instead.

If I copy the same shortcut file to E:\Program Files\Autoit3\SciTE\ or E:\Program Files\Autoit3\ then it works just fine too.

Any ideas why this happening and how to fix it?

 

Thank you.

 

scite.png

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Set the proper workdir when launching SciTE or set the environment variable SCITE_HOME to the proper directory.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

As it seen on the screenshot, workdir (start in) is set properly

environment variable is also out of question, because it's a portable SciTE..

Edited by VAN0

Share this post


Link to post
Share on other sites

Hmmm

I think I found the problem.

What happened was: I've installed SciTE over my portable version, which naturally "forgotten" all it's settings because now it was using settings from appdata and when I realized what happened I downloaded portable version and copied it over the installed version, which restored settings. But it must be something in registry or somewhere else that SciTE is using that overrides any portable settings. So I backed up SciTE folder and uninstalled it, then copied folder back from the backup and now SciTE is fully portable and working fine.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now