Xichael

SciTE-Lite Tabs 3 Spaces, Full Editor Tabs 4

9 posts in this topic

#1 ·  Posted (edited)

I've noticed when loading scripts I wrote using the lite version of SciTE into the full editor, that their tab entries are only 3 spaces wide, whereas the full editor's are 4. Was it set up this way intentionally?

Edited by Xichael

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Xichael,

Just add these lines to your "user options":

tabsize=#
indent.size=#

where "#" is the tab size you require, and you can set it to whatever value you wish.

M23

Edit: Or of course, use SciTEConfig to change it directly.

Edited by Melba23

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

It's fine. I've switched to the full editor and "Tidied" all my scripts.

I just wanted to bring it to the developer's attention in case the discrepancy wasn't intentional.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Just checked but it seems that SciTE-Lite also has a 4 space tab setting or am I missing something?

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Just that 3 spaces is the default for one, and 4 for the other. Might as well set them up the same out of the box so there's no inconsistency if moving from one to the other.

Share this post


Link to post
Share on other sites

Understood your remark, but that is not what I see. Looked at both default settings and they both seem to have 4 space tabs as default.

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Really? That's odd. I think I have the latest SciTE-Lite version (3.5.4) and I haven't changed the settings, but tab is doing 3 spaces. I'll see if reinstalling fixes it.

Share this post


Link to post
Share on other sites

...Nope. I uninstalled, wiped all traces of SciTE (including the full editor and any files in %UserProfile% and %LocalAppData%), reinstalled, opened a script and the indentation guides are all at 3 spaces.

Again, I don't mind as I use the full editor exclusively now, but I just thought I'd bring it to your attention.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now