ericbartha

UserCall Tips Not Working

9 posts in this topic

#1 ·  Posted (edited)

Hello everyone,

I am new to AutoIt, I've been using it for about 3 weeks now, so please excuse any ignorance on my part.

Anyways, I have created a UDF and am trying to get the ToolTip and syntax highlighting to work but have been very unsuccessful thus far. I created a User Include Folder under the config options and followed the instructions listed on the "User CallTip Manager" help page. I can see the UDF name, syntax, and desctription when I click the "View Tips" button but then when I go to use the UDF, it still does not work. I have restarted SciTe after saving all of these changes too.

Can anyone think of a reason why this still would not be working?

Note: I am on a work computer running Win7 Professional and the User Include Folder is a directory on a shared drive, if that matters.

Thank you in advance, everyone!

Edited by ericbartha

Share this post


Link to post
Share on other sites



You do have a file open with a .au3 file extension ...right?

What is the exact content of %localappdata%\AutoIt v3\SciTE\au3.user.calltips.api ?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Thanks for your fast reply, Jos.

Yes, I do have an .au3 file open.

When I open...    %appdata%\Local\AutoIt v3\    the only subfolder there is Aut2exe, which is empty. (I enabled hidden files/folders and still nothing.)

I take it this may be my issue, but I have no clue why.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Have you used the SciTE4AutoIt3 installer to install SciTE with its extra's? 

EDIT: where is your SciTEUser.properties located? (just open via SciTE menu option:  Options/ Open User options file.)

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

I do not know if install SciTE with extra's was used/enabled. I am new to this company and my workstation was configured for me. I can see about reinstalling SciTE.

The SciTEUser.properties file is located at:    C:\Program Files (x86)\AutoIt3\SciTE\SciTEUser.properties      and when I open it there are only two lines...

import au3.UserUdfs
import au3.keywords.user.abbreviations

Thoughts - or should I just try reinstalling?

Edited by ericbartha

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

I've moved away from installing it in that directory by default when the installer is used as the newer OSes (win7+)  by default have no write access in the programs directory.

What version of SciTE are you on?

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Understood. I still do not have admin rights here yet, so I will have to have one of the guys in the department take a look and reinstall it to a different directory.

I am on version 3.5.4.0, is this the latest release?

Share this post


Link to post
Share on other sites

You are one version behind, but the changes I referred to where made a year before that release.

It can all work fine when they've installed the ZIP file version (portable) but then it does require you to have write access to all its files or else it;s a little hard to save the changes. :)

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Understood. I will pass this along to one of the sysAdmins and see what they come back with.

Thanks a ton, Jos!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now