Sign in to follow this  
Followers 0
edkyo

CodeWizard ini file Getting You Down? rename it!

1 post in this topic

Firstly, This is my first post. Hello AutoiT World! Glad to have joined the forum. AutoiT is wonderful, and I thank you for it.

Now to my subject: If this subject has been solved in totality elsewhere my sincere apologies.

technical info: My version of AutoiT is v3.3.14.2 (full installer) My Version of scite4autoIT3 is 3.6.0 OS is Windows 8.1 64x You never know, someone always seems to ask. full install, default dir.

issue: I was trying to get the CodeWizard to work and it would not create-the-file-as-it-runs  .ini file. ..... so it seemed!  read the error closely as it pops up - follow that dir! Additional: Doing  a google search i found i wasn't the only one having this 'problem'. file/folder permissions is not this issue!

Doing a search into the hidden folders of my OS, specifically C:\Users\<YourUserName>\AppData\Local\AutoIt v3\SciTE\CodeWizard as the error popup tells us, The file "color.ini" was there! ...and thats the issue!

The file name in the directory above is color.ini, where the file name needed for the CodeWizard to work is colors.ini

lol!

The Answer: Just put a letter "s" in the file name to make the file name colors.ini. CodeWizard starts right up,  geeesh nice looking tool too; I think so.

don't believe me? check it out for yourself.

Lastly as for my self-solved issue, its in the code of the script too. humorously so, doing a 'find' in the CodeWizard script for colors.ini will show you that its typed as such in every location it should be (snazzy good looking code too), and searching for color.ini will get you nowhere. lol is this issue in the extractor portion of the installer of scite4autit3.exe? hmmm still curious as i could not find any error in the script not that i went over it with a fine toothed comb. i might have missed something. Or, as the installer starts spitting out files it just ejects the wrongly named file into the AppData dir? ...anyway, moving on.

I did uninstall/re-install just to make sure i wasn't leaving old files behind from older installs and different versions too. deleted all residual file/folders before re-install....same issue. its that little "s"! there ya go. hmmm, what about that Tidy issue of it not working for some...its all in the reading of those error msg's

did this help. if it did that's great! now go and write something Awesome with AutoiT.

eof edo out

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0