Jump to content

"Sleep" command

Recommended Posts


I am using the SLEEP command in my autoit script to manipulate and "time" mouse keystrokes precisely.  I am using sleep time intervals in the thousands, like 2338 for instance.  These milleseconds need to be precise.  When i first boot my pc and run the scripts they work perfectly and consistently.  But after my pc runs for a while, it seems that the intervals get out of synce slightly.  Can anyone tell me WHY this occurs, and if there is any way to resync the pc to allow for the millisecond precision Sleep times in my script?

thanks for any help!

Share this post

Link to post
Share on other sites

Maybe this will work - I haven't tried it though.

You might also get better results with TimerDiff(). You can also add code to compensate for drift in extreme cases.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.