Sign in to follow this  
Followers 0
Nunos

Compiling Error

4 posts in this topic

I have a script that I have used previously with no errors. I had to add a couple of new buttons to the GUI and now I can't get it to compile. Below is the error in the Console Box.

 

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /ShowGui /in "C:\Users\Nunos\Documents\Scirpting\AutoIT\In Progress and Researching\IDS Tools\IDS Tools.au3"
+>18:03:48 Starting AutoIt3Wrapper v.2.2.0.0 SciTE v.3.4.1.0   Keyboard:00000409  OS:WIN_81/  CPU:X64 OS:X64    Environment(Language:0409)
+>         SciTEDir => C:\Program Files (x86)\AutoIt3\SciTE   UserDir => C:\Users\Nunos\AppData\Local\AutoIt v3\SciTE\AutoIt3Wrapper   SCITE_USERHOME => C:\Users\Nunos\AppData\Local\AutoIt v3\SciTE
-> No changes made..
>Running Tidy (2.4.0.1)  from:C:\Program Files (x86)\AutoIt3\SciTE\tidy
+>18:03:54 Tidy ended.rc:0
>Running AU3Check (3.3.14.2)  from:C:\Program Files (x86)\AutoIt3  input:C:\Users\Nunos\Documents\Scirpting\AutoIT\In Progress and Researching\IDS Tools\IDS Tools.au3
+>18:03:54 AU3Check ended.rc:0
>Running:(3.3.14.2):C:\Program Files (x86)\AutoIt3\aut2exe\aut2exe.exe  /in "C:\Users\Nunos\Documents\Scirpting\AutoIT\In Progress and Researching\IDS Tools\IDS Tools.au3" /out "C:\Users\Nunos\AppData\Local\AutoIt v3\Aut2exe\~AU3qsnhkse.exe" /nopack /icon "..\..\..\..\..\..\..\Graphics\IDS.ico" /comp 2
+>18:04:01 Aut2exe.exe ended.C:\Users\Nunos\AppData\Local\AutoIt v3\Aut2exe\~AU3qsnhkse.exe. rc:0
>18:04:01 Performing the Program Resource Update steps:
...>Updating Program Version information.
>18:04:02 Program Resource updating finished successfully.
!>18:04:02 Problem copying file from: C:\Users\Nunos\AppData\Local\AutoIt v3\Aut2exe\~AU3qsnhkse.exe To :C:\Users\Nunos\Documents\Scirpting\AutoIT\In Progress and Researching\IDS Tools\IDS Tools\IDS Tools.exe
+>18:04:04 AutoIt3Wrapper Finished.
>Exit code: 0    Time: 16.32
 

 

I have tried running Sci-TE as Administrator and I have verified the permissions for the two directories and they appear to be right. Not sure what I am missing :(

 

 

Share this post


Link to post
Share on other sites



Maybe a instance of IDS Tools.exe was still active. So try again after restart.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

I have rebooted and tried to compile the script again and still received the error.

I also have tried disabling my AV. To no avail.

Uninstalled and reinstalled AutoIt and still received the compile error.

I was however able to copy the file from the appdata folder to the destination and rename it to IDS Tools and it worked fine.

Edited by Nunos
Added new information

Share this post


Link to post
Share on other sites

Update:

 

I uninstalled AutoIt and the SciTE Editor, then ran the registry cleaner in CCleaner, rebooted, reinstalled AutoIt and the SciTE editor, tested compiling my script and it worked.

 

Hope this helps someone someday if they have the same problem.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0